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EasyEDA Editor：https://lceda.cn/editor

EasyEDA Desktop Client：https://lceda.cn/download

 

Remark

This document will be updated as the new features of the editor are updated.
The latest revison please refer at EasyEDA Tutorials.pdf

Editor FAQ  

https://easyeda.com/editor
https://easyeda.com/download
http://club.szlcsc.com/article/details_40947_1.html
af://n36


 

Please spend a few minutes reading this FAQ, it will save you lots of time getting started with 
EasyEDA.

Tutorial  

Download for PDF  

EasyEDA-Tutorials.pdf

Video Tutorials  

Youtube - EasyEDA

Ask for Help  

Contact Us

Update Records  

Update Records

Schematic  

If I update the schematic, how do I then update the PCB?  

Using: "Menu - Design - Update PCB".

Alternatively, you can import changes from the schematic from within the PCB Editor:

https://docs.easyeda.com/en/PCB/Import-Changes/index.html

How to rename a Sheet/Page or modify description.  

In this menu, there is a Modify  option, so you can rename your files.  Double click or right-click 
the sheet tab can change the sheet title too.

 

What is the unit of the schematic sheet? How to change
schematic unit?

 

The basic unit of the schematic sheet is the pixel. 1 pixel is about 10mil (0.001 inch) but please 
note that this use of the pixels as a unit in a schematic is just for reference.

af://n40
af://n41
https://easyeda.com/forum/topic/PDF-EasyEDA-Tutorial-for-PDF-881302c7032b4d1697af1359ed9f6daa
af://n43
https://www.youtube.com/channel/UCRoMhHNzl7tMW8pFsdJGUIA/videos
af://n45
https://docs.easyeda.com/en/FAQ/Contact-Us/index.html
af://n48
https://easyeda.com/page/update-record
af://n51
af://n52
https://docs.easyeda.com/en/PCB/Import-Changes/index.html
af://n57
af://n60


For a complex project, I want to split the schematic over
several sheets. Does EasyEDA support hierarchy?

 

EasyEDA don't support hierarchy, but support multi-sheets。
Please check out this link https://docs.easyeda.com/en/Schematic/Multi-Sheet/index.html

How to change the sheet size and modify the design
information.

 

To change the sheet size, move the mouse anywhere over the lower right area of the drawing 
border or frame until the whole border highlights red and then right-click on it. Paper size and 
orientation can then be changed in Sheet Attributes  in the right hand panel.

To modify the design information, left-click on the relevant blue text in the lower right area of the 
drawing border or frame to change it in Text Attributes  in the right hand panel.  Double left-
clicking the blue text will allow you to type new information directly into the field. 

How to indicate low electronic level in the Schematic Pin or
Netlabel

 

af://n63
https://docs.easyeda.com/en/Schematic/Multi-Sheet/index.html
af://n66
af://n72


You can add a #  characater in the pin name/netlabel last text. You can use symbols that you are 
familiar with. You do not have to add a line above the netlabel name. 

I can't convert schematic to PCB. Why is this?  

1. You have not set the right footprints for your components. 
2. Prefix Conflict Error
3. Invalid footprints

 

PCB  

How to change the Units of PCB from mil to mm or inch.  

There is an option for that in PCB canvas attributes: 

 

How to pick and move the components on the PCB canvas
quickly.

 

Before routing the PCB, the components need to be positioned in suitable places on the PCB. In 
the PCB Editor, it can sometimes be quite difficult to select components by clicking on the 
silkscreen outline or the pads. To select and move them more easily, please use drag mode (Hot 
Key D ) or click the Move  icon in the PCB Tools toolbar:

af://n75
https://docs.easyeda.com/en/Schematic/Components-Prefix/index.html
https://docs.easyeda.com/en/PCB/Import-Changes/index.html#Invalid-footprints
af://n85
af://n86
af://n89


How to add test point in schematic or PCB?  

Schematic: You can place a single pin connector from EElib, and then update its footprint.

PCB: You can place a top/bottom layer pad , and then route it with track.

 

Can I create a PCB without creating schematic?  

Yes but for any but the simplest PCBs, please see:

Layout PCB Without Schematic

How to add more fonts for PCB.  

You can refer to Text of PCB section.

How to insert an Image/Logo to PCB.  

You can refer to Image of PCB section.

How to insert a DXF as board outline.  

You can refer to Import DXF File of Import section.

How to create non rectangular pcb outline such as round?  

You can import a DXF file for the board outline. For a round board outline, you can use an arc to 
do that, you just need to change to the board outline layer, then draw 1 arc like in the image 
below (need to adjust a bit later), you can use lines and arcs to create complex board outlines.

 

How to add a slot and cut out.  

Please use solid region https://docs.easyeda.com/en/PCB/PCB-Tools/index.html#Solid-Region

Or draw a track and right-click it, use the "Convert to Board Cutout" option.

How to measure dimensions on a PCB.  

https://docs.easyeda.com/en/PCB/PCB-Tools/index.html#Measure-Dimension

use Hotkey M

How to add more layers.  

af://n91
af://n95
https://docs.easyeda.com/en/PCB/Layout-PCB-Without-Schematic/index.html
af://n98
https://docs.easyeda.com/en/PCB/PCB-Tools/index.html#Text
af://n100
https://docs.easyeda.com/en/PCB/PCB-Tools/index.html#Image
af://n102
https://docs.easyeda.com/en/Import/Import-DXF/index.html
af://n104
af://n107
https://docs.easyeda.com/en/PCB/PCB-Tools/index.html#Solid-Region
af://n110
https://docs.easyeda.com/en/PCB/PCB-Tools/index.html#Measure-Dimension
af://n113


Click the layer options button, then tick the extra layers in the dialog that opens. 
https://docs.easyeda.com/en/PCB/Layers-Tool/index.html

How to add solder mask aperture.  

It is possible to get boards with the copper exposed so that you can apply a layer of solder over 
those tracks to further increase their current carrying capacity. In this case, you need to add 
solder mask over a copper (copper area, track, solid region). 
EasyEDA will add solder mask for pads automatically. Sometimes however, you may need to add 
an aperture in the solder mask to expose and area of copper.  

https://docs.easyeda.com/en/PCB/Layers-Tool/index.html
af://n115


1. First, add a top or bottom solder mask layer, as required.

   

2. Next, draw a region in the solder mask layer over a copper item as illustrated in the image 
below. This in effect draws an aperture in the solder mask so that the copper item inside the 
region, in this case the track, will be not be covered by the green film of solder mask.  

 

A common mistake is to just draw a solder mask, without a copper area, like the track pointed to 
by the yellow arrow. That is incorrect and does not produce the desired result.



Or you can click the track, and then click the Expose Copper  button at the right-hand panel. 

  

 

How do I set the dimensions of my PCB in the layout?  

PCB's dimension/size depends on the board outline, you can create your board outline, please 
refer to Board Outline of the PCB section.

My PCB is complex, how can I be sure that I have routed all
of the tracks?

 

Please refer to Design Manager of PCB section. 

I need to start my layout again, how can I remove all of the
tracks?

 

You can use "Menu - Route - Unroute All" and "Menu - Edit - Global Delete".

How to put a component on the bottom layer?  

There are two ways to do this.

1. If your active layer is the bottom layer, then every component you place will be placed on 
the bottom layer automatically.

2. You can place a component then select it and change its layer attribute to Bottom layer  in 
the right hand panel.

af://n126
https://docs.easyeda.com/en/PCB/Board-Outline/index.html
af://n128
https://docs.easyeda.com/en/PCB/Design-Manager/index.html
af://n131
af://n134


 

How to panelize the PCB  

Please refer at PCB: Panelize

What does Warning copper area do not allow self
intersection

 

Please refer at Forum: What does Warning copper area do not allow self intersection

 

Library and Parts  

How to create a schematic symbol library.  

File > New > Symbol

  

 

How to tag my schematic library symbol.  

After creating the library and saving, you can add a tag for it, and you can add and edit the tag at 
"Library":

af://n142
https://docs.easyeda.com/en/PCB/Panelize/index.html
af://n144
https://easyeda.com/forum/topic/What-does-Warning-copper-area-do-not-allow-self-intersection-mean-58299878caad44eebab3ffb316292348
af://n147
af://n149
af://n153


 

How to create sub parts for multi-part components.  

In personal part list, Right click the part then select Add Sub Part from the menu that opens:

   

How to change the footprint for a component.  

https://docs.easyeda.com/en/Schematic/Footprint-Manager/index.html

How to add sub parts to a schematic.  

You can add sub parts to a schematic one by one but please note that the sub parts prefix must 
be in the form of U1.1 U1.2 etc, and not U1.A U1.B.

af://n157
af://n159
https://docs.easyeda.com/en/Schematic/Footprint-Manager/index.html
af://n162


 

How to create a PCB footprint.  

  

How to change a component's footprint?  

please refer at Footprint Manager

 

How to find components/parts/libraries?  

The component search function has been significantly improved to make finding part symbols 
and footprints quicker and easier. Press SHIFT+F  or click on the Libraries  icon on the left 
navigation panel: 

In the new components dialog, it is easy to select the right components via tags and you can set 
tags for your own components.

 

Fabrication and Order  

How to Order PCB  

af://n166
af://n169
https://docs.easyeda.com/en/Schematic/Footprint-Manager/index.html
af://n172
af://n177
af://n179


1. Before ordering, please check this Gerber first: 
https://docs.easyeda.com/en/PCB/Gerber-Generate/index.html#Gerber-View

2. Visit and login at https://jlcpcb.com/quote
3. Add this Gerber file(compressed file) on the page and type the order options
4. Save to Cart, and then submit the payment

If you want to combine the components order with the PCB order at https://lcsc.com , please 
refer:
https://support.lcsc.com/article/24-do-you-offer-combine-shipment-with-pcbs

please refer at Order PCB

How export BOM and order parts?  

please refer at Export BOM

Import and Export  

How to import Alitum/Eagle/Kicad File?  

Please refer at Import Altium Designer

Can I export my design?  

Yes, you can export your design as EasyEDA format or Alitum Designer format. Please refer at:

Export EasyEDA format

Export Alitum Designer Format

How to export or print the schematic or PCB?  

please refer at Export

Save and Backup  

Where are my files?  

Your files are stored on EasyEDA servers, so you can access them anywhere and share them with 
your partners.

if you using EasyEA desktop client, you can set the runing mode as "Project Offline Mode", it will 
save your project to local.

How to save my file to the local?  

You can download the project via :

Right-click project and download; 
Download the EasyEDA Source
Export to Altium file Export: Export Altium

How to recover the deleted file?  

1. Check "Recycle Bin" at the editor bottom-left icon, find and recovery
2. Find it back at "Document Recovery" function. Via:  - Advanced - Document Recovery.

https://docs.easyeda.com/en/PCB/Gerber-Generate/index.html#Gerber-View
https://jlcpcb.com/quote
https://lcsc.com/
https://support.lcsc.com/article/24-do-you-offer-combine-shipment-with-pcbs
https://docs.easyeda.com/en/PCB/Order-PCB/index.html
af://n192
https://docs.easyeda.com/en/Schematic/Export-BOM/index.html
af://n195
af://n196
https://docs.easyeda.com/en/Import/Import-Altium-Designer/index.html
af://n198
https://docs.easyeda.com/en/Export/Export-EasyEDA-Source-File/index.html
https://docs.easyeda.com/en/Export/Export-Altium/index.html
af://n202
https://docs.easyeda.com/en/Export/Export-Schematic/index.html
af://n205
af://n206
af://n210
https://docs.easyeda.com/en/Export/Export-EasyEDA-Source-File/index.html
https://docs.easyeda.com/en/Export/Export-Altium/index.html
af://n220


I don't like others seeing my design. How can I stop that
happening?

 

Set your project as Private. For extra security you can even save your work locally.

as above to save your file to locad as EasyEDA format.

Is EasyEDA safe?  

There are no absolutely secure things in the world but even if you have the misfortune - as 
happened to one of our team - of losing one laptop and having two hard drives break, 
EasyEDA will try to protect your designs in following ways:

1. We utilize SSL throughout the entire domain EasyEDA.com. Secure Socket Layer (SSL) 
technology encrypts all data transferred between your computer and our servers. Your data 
is for your eyes only.

2. You can save your files locally.
3. Multiple copies of every file are saved in your local database. 
4. EasyEDA servers backup your designs frequently.

What if EasyEDA cannot become self sustaining and has to
close down?

 

We promise to do our best to ensure that neither of these things will happen; we have spent so 
much of our time to get to this point. We promise that if we cannot make enough money out of 
EasyEDA to keep it alive or to fund further development, we will not simply abandon our baby or 
our community but we will consider donating the code to the Open Source Community to let 
them build on our efforts. There are no companies who can stay forever, so if a time comes when 
we have to close down,  we will follow the steps below:

1. Give our users six months warning prior to closure;
2. Ensure all our users can backup their designs;
3. Ensure that user's designs can be exported to some other EDA tools, such as Kicad, Altium 

Designer and others.
4. Package our codes, so that users can install an EasyEDA in their own OS (Windows, Linux, 

Mac). Users can then build their own cloud EDA.
5. Upload our codes to github.com and make them open source.

So, nothing will be lost and our users can continue to enjoy an awesome web based EDA tool that 
lets them stay in charge of their designs: anywhere, anytime and on any OS.

How to backup my project?  

Please refer at: Saving Your Work Locally

Spice Simulation FAQ  

EasyEDA's main target is schematic and PCB, not simulation. EasyEDA only support simple 
schematics simulation.

How to set the resistance of a resistor  

   You can use the name attribute. Just set the name or double click the value text.

af://n227
af://n231
af://n243
af://n258
https://docs.easyeda.com/en/Introduction/Basic-Skill/index.html#Saving-Your-Work-Locally
af://n261
af://n263


  

 

Where Can I find the Probe/voltage probe?  

  Voltage probe 

   

Why I can't simulate my schematic  

   EasyEDA only has very few simulation models, EasyEDA is powered by LTSpice, please check 
LTspice to know what can be simulated.

How to ask for help and get an answer  

 [Must read] How to ask for help and get an answer

 

Others  

Can I use EasyEDA in my company?  

You are free to use EasyEDA for individuals, business and education.
If you add our Logo and link on your PCB/Video we will appreciate.

What happens if EasyEDA service is offline for some reason?  

EasyEDA can be run as an offline application. You can export your design first, when the service 
back, you can import the design and save to EasyEDA server.

Or you can use EasyEDA desktop client "Project Offline" mode.

 

How to find the list of hotkeys.  

af://n267
af://n269
af://n271
https://easyeda.com/forum/topic/How-to-ask-for-help-and-get-an-answer-71b17a40d15442349eaecbfae083e46a
af://n274
af://n275
af://n278
af://n283


Please refer at Introduction: Shortcut Keys

Why does EasyEDA focus on Cloud based EDA?  

EasyEDA is built for people who like to work anywhere, who like to build projects together with 
other team members, who like to share their projects, who like something that operates like a 
github for hardware design. The only way to meet these needs is to build a Cloud version EDA.

How can I work if there is no internet?  

Although most of the time there are ways to access the internet easily and cheaply there may be 
times when, for whatever the reason, internet access is simply not possible. For times like this, 
EasyEDA is working to provide a desktop client soon.

Does EasyEDA have a desktop version?  

Yes, please refer at: https://easyeda.com/page/download

Which Browser is best for EasyEDA?  

  The latest Chrome and Firefox. If you are restricted to using other browsers, it would be better 
to download the EasyEDA desktop client.

How to go to your dashboard.  

In the User Center, you can check all your Projects, Modules, Libraries and Friends, Messages etc.

There are two ways to arrive there.  

1. From the Editor, you can click on user logo:

2. From the homepage, you can click My Projects:

 

How to delete a project.  

https://docs.easyeda.com/en/Introduction/Shortcut-Keys/index.html
af://n286
af://n288
af://n290
https://easyeda.com/page/download
af://n293
af://n295
https://easyeda.com/account/user
af://n304


Select it and right click to open a context menu, like the image below.

How to delete a schematic or PCB.  

Select it and right click to open a context menu, like the image below.

 

How to share a project with others.  

1. Make your project public.  

af://n306
af://n310


  

2. To share a project privately with only selected collaborators via:
Add Member   

How to find the version history of schematics and PCBs.  

The version history of your EasyEDA schematics and PCBs can be accessed by right-clicking on 
the file you wish to query to open the context menu as shown in the image below: 

  

Then click on the version number that you wish to view.

Note: saving a previous version will restore that version to being the current version of the file.

 

 

Does EasyEDA canvas use the Cartesian coordinate system?  

 Yes and no. 

 It uses X and Y coordinates where the horizontal X coordinate is positive to the right of the origin 
and negative to the left but the vertical Y coordinate is positive below the origin and negative 
above it. 

 Actually, we think our coordinate system is not very good but it is hard to change. 

https://docs.easyeda.com/en/Introduction/Project-Member/index.html
af://n319
af://n326


  

How to update editor to latest version and how to remove
editor cache?

 

please refer at: How to Update

   

Essential checks before placing a PCB order  

Please refer Essential checks before placing a PCB order

 

Keep in Mind  

1. After the first save of any file, EasyEDA will back up all saved files automatically under the 
Version Control. If you want to back up your files locally, you can download a copy of the 
whole project or of individual files in a project in EasyEDA Source (JSON) format:

af://n331
https://docs.easyeda.com/en/FAQ/About-Update/index.html
af://n334
https://easyeda.com/andyfierman/Essential_checks_before_placing_a_PCB_order-de51f1401cec4bd2896ea835aca67db8
af://n337
https://docs.easyeda.com/en/Introduction/Version-Control/index.html


and File > EasyEDA File Source > Download

2. If you need help, you can contact us email or ask via our Support Forum; we will respond 
ASAP.

 

 

 

 

EasyEDA Desktop CLient  
 

Download  

Download address: https://easyeda.com/page/download

Client Running Mode  

When you install the client first time, you can set the runing mode:

https://easyeda.com/forum
af://n348
af://n350
https://easyeda.com/page/download
af://n352


if you want to change the runnig mode after installation, you can via: Top Menu - Setting - 
Desktop Client Setting - Running Mode Setting

or right-click the start page, via: Setting - Switch Run Mode



Team Work Mode

This version is full function, such as team work, work any time any where. 
Project and library are saving at cloud server.

Projects Offline Mode

Project save at local, the library save at the cloud. Only few option needing internet, such as: 
library searching, library saving, schematic convert to PCB, import changes, etc.

Full Offline Mode

Doesn't provide yet. 

Projects and libraries are saving at local. It is only provide for company. That will take some cost.

Client Setting  

Right-click the start page, visit the setting menu. or at：Top Menu - Setting - Desktop Client 
Setting 

New Editor Window: Create a new editor window.

Reload: You can reload the editor.

Zoom: Zoom in or zoom out the editor windows.

Setting:

af://n366


Remove Cache: Clear editor cache.

Data Saving Directory: Including offline projects and auto-backup projects saving 
directory. When you using "Team Work Version", the client will auto-backup your file to 
this directory, which is named "projects_backup", each signle file you saved will be 
saving in this directory, if you want to recovery the file from this directory, you can 
open the backup file at the editor. Or you can use editor Document Recovery function 
too.



How to import online project into project offline version in batch?

1, first download project backup to local: backup project

2, after downloading and then decompression, to get the projects separate compression files, 
each compression file separately decompression in a folder.

3, copy the unzipped project folder to the offline project save directory.

4, then open the client, the client will automatically scan the newly added directory to generate a 
list of projects. 

Note:

Please do not directly modify the name of the document in the folder in explorer, and do not 
directly copy and paste the new document in the folder, otherwise the editor will not be able to 
properly recognize the newly added document. Please go through the editor " - File - EasyEDA File 
Source..." Proceed to add new documents into the project.
The too old client version doesn't allow to use, the dialog will tell you the version is expired, please 
download the new version to install.
Doesn't support to upgrade automatically yet, please download and install manually.

Known Issue  

1.When client running mode is "Project offline", it doesn't support to open the public project at 
Explore, and can not open the cloud project too.

-   **Version Setting**: Modify the running mode you need.

-   **Check Update**: Check the client version.  

1

2

3

https://easyeda.com/account/user/projects/all?from=editor&cmd=backup_projects
af://n398


2.If you login with Google account, it will show the client is not secure, please refer at this post 
Can't login via Google Accout

  

Please reset your password to get the password Reset Password   

1.Hit password reset link above  
2.enter gmail email address and hit reset, keep track of your new password  
3.now log in "normally", typing in your gmail address and password, not hitting the "login 
with Gmail" button.   
4.this issue is Google block other browsers, you can search this issue at Google

 

3.Windows: Some windows systems can not run EasyEDA client well, or some PCs need some 
times to loading the login page, 
if you met the dialog blank screen all the time when open the client, please try below steps:

Close client
1.Open CMD window dialog by administrator 
WIN + R , input cmd, then enter.

  

https://easyeda.com/forum/topic/Cant-login-to-EASY-EDA-Widnows-a0302bbe79234f2c8ad7167b0f2cedc0
https://passport.easyeda.com/password/reset?service=https%3A%2F%2Feasyeda.com%2Flogin%3Ffrom%3Dhttps%3A%2F%2Feasyeda.com%2F


2.Input this at cmd window: netsh winsock reset

  

3.Enter
4.Open client again. Maybe need to restart the computer.

4.Linux OS: Show segement fault while runing the client. That is system capability issue, any 
chance to upgrade the OS version.

5.Mac OS: Can't install isse: How to open apps from unidentified developers on macOS Sierra

How to Update  
 

Version Rule  

EasyEDA version number is 
ReleaseCountsOfThisYear.MajorVersion.ReleaseCountsOfThisMajorVersion . For example, 
v4.9.3 is the fourth year released of EasyEDA, and  nine major versions are released in this year, 
EasyEDA had released 3 times in this major version.

Version Upgrade  

If you use EasyEDA online, it can seamlessly upgrade by itself. However,EasyEDA uses an App 
Cache technique to allow you to use EasyEDA offline (W3C HTML5 Offline Web Applications) 
which may delay the automatic upgrading process. Therefore, if you want to upgrade to the 
latest version immediately, you can follow the two simple steps below.

1. Check the About... dialog; 
2. If the Built Date is older than 2017/06/01:

Close your browser open EasyEDA again.
If the Built Date is still showing older than 2017/06/01:
Close your browser and open EasyEDA again.
If the Built Date is at or newer than 2017/06/01, you don't need to do anything.

Note: 2017/06/01 is just an example.  

If those two steps don't work, you may need to clear your browser's cache:

Mozilla Firefox  

Close the editor, Go to “Preferences… > Privacy & Security > History > clear your recent 
history” or use Ctrl+shift+Delete,
Click on “Clear now”,

https://www.imore.com/how-open-apps-unidentified-developers-mac
af://n427
af://n430
af://n432
http://dev.w3.org/html5/offline-webapps/
af://n442


Reload easyeda again.

  

Chrome  

Close the editor, Open the following URL: chrome://appcache-internals/ .

Look for easyeda.com and click “Remove”.  

Reload easyeda again.

 

 

af://n451


Or you can use hotkey Ctrl+shift+Delete to delete Chrome caches.

 

 

Desktop Client  

Close client and re-open it.
If doesn't work, rght-clik start page, use "Inspect Electment".

Switch to "Application" - "Clear storage", enable "Cache storage" and "Application cache", 
then click "Clear site data".

af://n462


Restart Client.

 

User Center FAQ  
 

How to change password  

Via: User Center > Account > Password Setting

How to recover the deleted file  

Via: User Center > Recycle Bin

Find the file you want and then recover it.

How to transfer project or library to the team  

Transfer project: Enter the project, via: Setting > Advance Setting > Transfer Project

Transfer library: Move the mouse to the library, and then click the transfer icon.

How to delete project  

Via Project > Manage > Setting > Advanced > Delete Project

 

Contact Us  
 

Contact  

af://n474
af://n476
af://n478
af://n481
af://n484
af://n487
af://n489
af://n490


PCB Order Problems:  

   

At present, EasyEDA PCB service is transfer to JLCPCB.com , we are the same company 
group, any PCB orders problem please contact with JLCPCB .   

 

Parts Order Problems:  

 

EasyEDA provides direct links to LCSC thousands of components. Please order at LCSC.COM, 
any parts order problem please contact with LCSC .   

All Other Inquiries About EasyEDA:  

Tutorials:  EasyEDA tutorial
User forum:  EasyEDA forum
If you met some problems with design, please attach your design by EasyEDA source file and 
how to repeat the issue. 

 

 

Notice  

EasyEDA team may not have the time or resources to help you fix all your problems; we may just be 
able to help you to fix problems commonly encountered by newbies, such as using a drawing polyline 
in place of a wire, finding a spice model for a simulation or selecting the right PCB footprint.

Please note that although some browsers or plug-ins allow you to use gestures, EasyEDA does not 
work with gestures, so you should disable this function.
Simulation editing is not yet fully supported: care must be taken because the last save by any 
collaborator overwrites all previous saves.
It can also find the value text but it cannot step through multiple components with the same 
value.
Take a few moments to think about your username because this is the name that other users will 
see on your designs and posts if you choose to share them or make them public. Once you have 
created an account, you cannot change your username.
You can use upper and lower case letters, numbers and symbols to make a strong password but 
don't forget that the password entry is case sensitive.
Except ordering of PCBs directly from EasyEDA.
If you always open EasyEDA in the same browser on the same machine, your Anonymous files will 
appear under the Anonymous Files folder in the left hand panel but you should not rely on this as 
a way of keeping track of Anonymous files.
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Business Development/Cooperation About
EasyEDA:

 

please contact 

 

 

Address:  

F5, Tianjian Building, No.7 Shangbao Road, Futian District, Shenzhen, Guangdong, 518000, 
China   

                                        

 

 

 

Introduction to EasyEDA  
 

Welcome to EasyEDA, a great web based on EDA(Electronics Design Automation) tool for 
electronics engineers, educators, students, makers and enthusiasts. 

There's no need to install any software. Just open EasyEDA in any HTML5 capable, standards 
compliant web browser.

Whether you are using Linux, Mac or Windows,Highly recommend to use Chrome or Firefox as 
your browser ,you can also download EasyEDA client.
EasyEDA has all the features you expect and need to rapidly and easily take your design from 
conception through to production.

EasyEDA Editor: 

https://easyeda.com/editor  

Instruction:   

This tutorial document will be updated according to the updated EasyEDA editor.

Tutorial for PDF

EasyEDA-Tutorials.pdf

EasyEDA Provides:   

Simple, Easier, Friendly, and Powerful general drawing capabilities

Working Anywhere, Anytime, Any Devices

Real-time Team Cooperation

Sharing Online

Thousands of open source projects
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Integrated PCB fabrication and Components purchase chain

API provide

Script support

Schematic Capture

LTSpice-based Simulation
Spice models and subcircuits create
WaveForm viewer and data export(CSV)
Netlist export(Spice, Protel/Altium Designer, Pads, FreePCB)
Document export(PDF, PNG, SVG)
EasyEDA source file export(json)
Altium Designer format export
BOM export
Mutil-sheet schematics
Schematic module
Theme setting
Document recovery

PCB Layout

Design Rules Checking(DRC)
Mutil-Layer, 6 copper layer supported
Document export(PDF, PNG, SVG)
EasyEDA source file export(json)
Altium Designer format export
BOM export
DXF export
Photo view
3D View
Generate the fabrication file(Gerber)
Export Pick and Place file
Auto Router
PCB module
Document recovery

Import

Altium/ProtelDXP ASCII Schematic/PCB
Eagle Schematic/PCB/Libraries
KiCAD Schematic/PCB/Libraries
DXF

Libraries

More than 1000,000 public Libraries(Symbol and Footprint)
Libraries management
Symbol/Subpart create and edit
Spice symbol/model create and edit
Libraries management
Footprint create and edit
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Design Flow by Using EasyEDA  
You can create circuits design easily by using EasyEDA. The design flow as below:

af://n672




 

UI Introduction  
 

EasyEDA Editor has a clearly and friendly user interface. You can use its every function very easily 
when you become familiar with EasyEDA.

Filter  

Before using the Filter, you need to select what module you need in the left navigation panel, and 
then you can find projects,files, parts and footprints quickly and easily just by typing a few letters 
of the title. For example, if you want to find all files containing “NE555” in the title, just type “555”, 
it is non-case-sensitive.

  

The Filter could only find projects, files and part titles and names. It does not support the 
Descriptions and Content fields.

Click the X to clear the filter.

Navigation Panel  

The Navigation panel is very important for EasyEDA: The part that you can find all your projects, 
files, parts and footprints.

  

Project  
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Here, You can find all of your projects that are private or shared with the public, or fork from 
someone else's. These options have a content menu when you drop down to Projects and right 
click an item, you will get a tree menu like :

 

EELib  

EElib means EasyEDA Libraries, It provides lots of components completed with simulation 
models, many of which have been developed for EasyEDA to make your simulation experience 
easier.  

Design Manager  

af://n689
af://n691


Design Manager, you can check each component and net easily, and it will provide DRC(Design 
rule check) to help your design better.

Library  
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Contains schematic symbols and PCB footprints for many available components and projects and 
your own libs and modules will show up here.

LCSC
If you want to buy components to finish your PCBA, you should try the LCSC module, 
LCSC.com and EasyEDA are the same company.
EasyEDA partners with China's largest electronic components online store by customers and 
ordering quantity launch https://lcsc.com.
LCSC means Love Components? Save Cost! We suggest to our users to use LCSC parts to 
design. Why?  

Small Quantity & Global Shipping.  
More Than 25,000 Kinds of Components.  
All components are genuine.   
It is easy to order co after design.   
You can save 40% cost at least.  
You can use our components' symbols and footprint directly in EasyEDA editor.  

JLCPCB
JLCPCB.com, LCSC.com and EasyEDA are the same company group.  https://jlcpcb.com
More than 200,000 customers worldwide trust JLC, 8000 + online orders per day,JLCPCB 
(Shenzhen JIALICHUANG Electronic Technology Development Co.,Ltd.), is the largest PCB 
prototype enterprise in China and a high-tech manufacturer specializing in quick PCB 
prototype and small-batch production.Affordable, series quality boards fully manufactured 
in China. Fully e-tested. Transparent pricing.

Top Menu  

A most of EasyEDA features can find out at top menu:

You can find what you need easier and clearly.

Preview Dialog  

The Preview dialog will help you choose components and footprints and can help you to identify 
schematics and PCB layouts.

https://lcsc.com/
https://jlcpcb.com/
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You can close or open this dialog via:  

 Top Menu > View > Preview Window.

  

The Preview Dialog has a resizing handle in the bottom right corner.
The Preview Dialog can't be closed but double clicking on the top banner will roll up the 
panel or you can click the top right corner —  . Double clicking top banner again toggles it 
back to the selected size.    

Wiring Tools  

Wiring Tools are document type sensitive: different document types have different tools.

Drawing Tools  

To keep EasyEDA's UI clean and sharp, the Wiring and Drawing tools palettes can be resized 
horizontally, rolled up or hidden so if you want to focus on drawing, you can roll up or hide the 
others to make more space and reduce the clutter.    
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Canvas Attributes  

You can find the canvas Properties setting by clicking on any of the blank space in the canvas. 

Background and grid colors and the style, size, visibility and snap attributes of the grid can all be 
configured.

The canvas area can be set directly by the Width and Height or from available preset frame sizes.

Canvas  

This is where it all happens! This the area where you create and edit your schematics, PCB 
layouts, symbols, footprints and other drawings, run simulations and display WaveForm traces.
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How to Create a New Project or File  

Create Project  

After logging in, you can create a new project:

 File > New > Create a new project/Schematic..etc

  

The Project concept is important in EasyEDA because it is the foundation of how to organize your 
designs.
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Owner: You can change the owner of this project, you can change the owner to the team if 
you have joined.
Title: Give it a title: this will show in the project tree in the left hand panel.
Path: EasyEDA allows you set the path for the project, if you want to share with your friend, 
it will be useful. It can't be editable when it is created.
Description: Adding a short description helps you and anyone you are sharing this project 
with understand what the project is about.

Once created, to modify your project, right click on it in the project tree in the left hand panel: 

  

then will open a web page in which you can edit your project:



From here, you can change the publish or not, allow other people to comment on your project 
and type a more detailed description of the project content. To help you make your project stand 
out or to maybe simply make a detailed description of your project easier to read, you can use 
Markdown syntax.

Open Project  

You can open your created porject via:

Top Menu - File - Open Project

  

Or click the Opened Project "open project" icon
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Select the project and open it.

 

Schematic Capture  
 

EasyEDA can create highly professional looking schematics.
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Because EasyEDA has some simple but powerful drawing capabilities, you can create your own 
symbols either by copying existing symbols into your own library and then editing and saving 
them, or by drawing them from scratch.

There is also a Symbol Wizard to quickly draw new symbols for DIP , QFP  and SIP

  

A feature of EasyEDA is that as well as extensive libraries of the usual simple “2D” graphical 
schematic symbols, it has a library of drawn 3D  component symbols, i.e. symbols that look like 
the physical components that they represent.

If you have enough time and patience using the drawing features to full effect in symbol 
creation, your schematic can be built like this:

Another powerful feature is that it is also possible to import symbols from Kicad , Eagle  and 
Altium  libraries.

 

PCB Layout  
 

When you are satisfied with your schematic design and simulation results, you can then quickly 
proceed to produce your finished and populated PCB without leaving EasyEDA.
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EasyEDA's PCB Design canvas helps you to quickly and easily lay out even complex multilayer 
designs from schematics you have already created in the Schematic canvas or directly as a layout 
with no schematic.

Passing an EasyEDA Schematic into the PCB Design editor is as easy as clicking a button: Just 
click the Convert to PCB via: "Menu - Design - Convert to PCB".

  

EasyEDA has extensive footprints. You can also build up your own library of unusual and 
specialized parts by copying and modifying existing parts or from scratch using EasyEDA's 
powerful footprint creation and editing tools.

  

In a similar way as in the Schematic design canvas, to help you locate items and navigate 
your way around when working in the PCB Design canvas there is a PCB Design Manager.
Left Navigation Panel > Design Manager
The PCB Design Manager is a very powerful tool for finding components, tracks (nets) and 
pads (Net Pads).
Clicking on any item highlights the component and pans it to the center of the window.

  

You can set up layers used in the PCB and their display colours and visibility using
Top Menu - Tools - Layer Manager...



The active layer and layer visibility can be selected using the Layers Toolbar.

  

 

 

Default track widths, clearances and via hole dimensions can all be configured in the Design 
Rule Check dialog which is opened via:
Top Menu > Design > Design Rule...

From first setting up the Design Rule Check (DRC) at the start of your board layout, running 
a DRC is almost the last step in checking your PCB design before you generate Gerber and 
Drill files for board manufacture ready to place your order for a finished PCB.
The last step is to check the Gerber and Drill files using an easy way it is to install and use 
Free and Open Source Software Gerber Viewer: Gerbv: http://gerbv.geda-project.org/ 
While you are waiting for your PCB to be delivered, you can create a Bill of Materials (BOM) 
via:

http://gerbv.geda-project.org/


File > Export BOM... or Top Menu - Fabrication - BOM...

  

 

And you can produce professional quality SVG , .png  or .pdf  output files for your 
documentation.  

PCB Designs can be shared with colleagues and made public in the same way as Schematics.
The size of PCB that you can produce using EasyEDA is almost unlimited: designs of over 100cm * 
100cm are possible … but you might need a powerful computer for that.  

EasyEDA supports up to 6 layer PCBs by default but it is capable of handling more, so if you need 
more layers then please contact us.  

Search footprints  

Searching footprints is the same as searching symbols by using Library in the Schematic.
You can place the selected footprints in the canvas after the search.

 

 

Libraries Management  
Thanks to the Free and Open Source Kicad Libs and some Open Source Eagle libs, EasyEDA now 
has 700,000+ components, which should be enough for most projects.

Now you can enjoy using EasyEDA without having to spend so much time hunting for or building 
schematic symbols and PCB footprints.  

Library
On the left hand Navigation panel you will find "EElib" and "Library", just type what 
components you want and search.
At Libraries:
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Steps: 

1.Choose the library type
2.Typing the keyword such as "1k 0603"
3.Click the search button
4.Select the class you which is wanted of the result
5.If you don't need the search you need to remove all the search keywords

Create Library
EasyEDA supports creating symbols by yourself, after created you can find out your 
components at Library > Symbols/Footprints > Workspace, and it is easy to manage your 
libraries.

Transfer Libraries 
If you want to transfer your libraries to the team, you can do that in "User Center > Libraries 



> Personal".

To prepare for the final assembly stage you can create a Bill of Materials (BOM) via: File > Export 
BOM...

and you can produce professional quality SVG , .PNG  or .PDF  output files for your documents.

All EasyEDA Schematic Symbol and PCB Footprint libs are public, so after you have created and 
saved a new symbol or footprint, others will be able to find your part and you will be credited as 
a contributor.   https://easyeda.com/page/contribute

 

 

Version-Control  
EasyEDA provide a simple but powerful version control feature. Each version is independent, you 
can edit and save for every version.
When create the new project, it will be set the default version name as "master", you can edit the 
name at the "Project Manage - Version" page.

You can create 10 versions for every project. The more versions you need to delete the older 
first.

Create New Verison  

Via: Project folder - right-click menu - Version - New Version

At the new version dialog, you need to type the version's name and description, and create it.

If you want to switch to new version, you have via "Version - Switch Version".

https://easyeda.com/page/contribute
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Switch Version  

Click "Switch", the dialog will list current version and all version for this project, you can select 
one and switch to it.

Notice:  

Before switching the other version, you have to close the current version's document 
manually first.
You only can open the current version's document, if you want to open other's version's 
document, you have to swicth the version first.
If you not sure which verison it is, you can check it at "Switch Version" dialog to check 
"Current Version", or hover the mouse cursor on the project folder.
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Version Management  

Via "Version Management", will open the "Project Page - Version".
Version page will list all versions, you can edit the versions' name and description, or delete 
them. Current version can't be deleted.

 

Share with Public  
Sharing your work with others is a big feature of web based EDA tools and EasyEDA is no 
exception in offering you some nice features.

Did you create a really cool project with EasyEDA? Show it off and be super helpful to other 
EasyEDA users, you just need to set your projects to public, so others can explore your circuits.

All projects in EasyEDA are set to private by default, your private project can not be shared with 
anyone.
i.e. to make it public, you should right click and edit your existing project to be a Public project:      

At the Workspace, click Share icon when the mouse hover the project cover, it will ask you 
to confirm.
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Or enter project manage page, via "Workspace > Project > Manage > Settings > Basci > 
Project proerty:Public"

  

At the editor, you can right-click the project, click the Share  menu, after setting the project 
as public.

  

 



 

Project Member  
How to share project with selected people?

Can you share a private project with your partner? Can your partner modify your designs?

Yes, you can use Member to do this.

Right click the project and you will see the Member on the context menu; clicking on it will open 
the Member webpage.  

  

So if you want to share a project with someone,

1. You just need to know their E-mail address which they have used to create an account with 
EasyEDA

2. The project member you can set as "Developer","Manager",and "Observer".

After setting up Member and Permissions, your partner will find your project in the Open 
Project when they login.

If you partner doesn't wish to accept the shared project, they can reject it by leaving the project 
when they enter this project "Member" function.

 

User Preference  
When EasyEDA shows up the login success pop up in the bottom right of the window, your user 
management menu will be look like this:

Click on Top Menu - Setting - User Preferences,  
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Document Recovery Setting:

Maximum backup level: Every opened document can be saved as a backup to this number 
of different revisions.
Auto backup interval: This is the time interval between auto saves of all your opened 
documents.

The Document Recovery function you can find at:  

  

 

 

 

Shortcut Keys  
 

After a while of using an EDA tool suite, clicking all over the place with a mouse gets very tedious 
and seriously reduces your productivity. Keyboard shortcuts or Hotkeys avoid much of 
that. EasyEDA not only provides lots of hotkeys, but also every hotkey can be reconfigured.

af://n922


Under the Setting menu, click the Hotkeys Setting... Menu which will open the Hotkey 
Setting dialog.

  

 

To change a Hotkey, click anywhere in the row for the hotkey you want to change and then press 
your new key.

For example, if you want to use  R  instead of space  to rotate selected objects, click on the first 
row, then press  R .

After you change the hotkey, don't forget to click Save Changes button.

The docType column describes which type of EasyEDA document each hotkey applies to. 
docType has three types:

ALL: any document type in EasyEDA.
SCH: schematic and schematic libs
PCB: PCB and Footprints.

The functions of some hotkeys may change between docTypes. For example, the hotkey  C  draws 
an Arc in SCH, but draws a circle in PCB.

A list of all the available default hotkeys is given below. 

All document  
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DocType Shortcut Function

All Space Rotate selected objects

All Right-Click
Keep right-click to pan canvas; Open offset dialog when
select one object

All Left Scroll Or Move selected left

All Right Scroll or Move selected right

All Up Scroll or Move selected up

All Down Scroll or Move selected down

All TAB
Change object's attributes when placing; Open offset dialog
when select a object

All Esc Cancel current drawing

All Home setting new canvas origin

All Delete Delete Selected

All F1 Open tutorials

All F11 Full screen at browser

All A Zoom In

All Z Zoom Out

All D Drag

All K Fit Window

All R Rotate selected objects

All X Flip Horizontal(doesn't support footprint)

All Y Flip Vertical(doesn't support footprint)

All ALT+F5 Full screen at browser

All CTRL+X Cut

All CTRL+C Copy

All CTRL+V Paste

All CTRL+A Select All

All CTRL+Z Undo

All CTRL+Y Redo

All CTRL+S Save

All CTRL+F Find Component

All CTRL+D Design Manager



DocType Shortcut Function

All CTRL+Home Open canvas origin setting dialog

All SHIFT+1 Cycle forward to next open tabbed document

All SHIFT+2 Cycle backward to next open tabbed document

All SHIFT+X Cross Probe

All SHIFT+F Search Library

All SHIFT+Drag Cursor snap to part's origin

All SHIFT+ALT+H Align horizontal centers

All SHIFT+ALT+E Align verticas centers

All CRTL+SHIFT+L Align left

All CRTL+SHIFT+R Align right

All CRTL+SHIFT+O Align top

All CRTL+SHIFT+B Align bottom

All CRTL+SHIFT+G Align grid

All CRTL+SHIFT+H Distribute Horizontally

All CRTL+SHIFT+E Distribute Vertically

All CTRL+SHIFT+F Find similar objects

 

Schematic  
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DocType Shortcut Function

Schematic W Draw Wire

Schematic B Draw Bus

Schematic U Bus Entry

Schematic N NetLabel

Schematic P Place Pin

Schematic L Draw Polyline

Schematic O Draw Polygon

Schematic Q Draw Bezier

Schematic C Draw Arc

Schematic S Draw Rect

Schematic E Draw Ellipse

Schematic F Freehand Draw

Schematic T Place Text

Schematic I Edit Selected Symbol

Schematic CTRL+Q NetFlag VCC

Schematic CTRL+G NetFlag GND

Schematic F8 Run the Document Simulation

Schematic CTRL+J Open the Simulation Setting

Schematic CTRL+SHIFT+X Cross Probe and Place

PCB  
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DocType Shortcut Function

PCB W Draw Track

PCB U Draw Arc

PCB C Draw Circle

PCB N Draw Dimension

PCB S Draw Text

PCB O Draw Connect

PCB E Draw copperArea

PCB T Change To TopLayer; Change selected part to toplayer

PCB B
Change To BottomLayer; Change selected part to
bottomlayer

PCB 1 Change To Inner1

PCB 2 Change To Inner2

PCB 3 Change To Inner3

PCB 4 Change To Inner4

PCB P Place Pad

PCB Q Change canvas unit

PCB V Place Via

PCB M Measure

PCB H
Highlight Net all the time, press it again cancel
highlight

PCB L Change Route Angle

PCB -
Decrease Routing Width; Switch to the forward signal
layer

PCB + Increase Routing Width; Switch to the next signal layer

PCB * Cycle switch to the next signal layer

PCB Delete Delete selected object; Undo the track when routing

PCB ALT-- Decrease Snap Size

PCB ALT++ Increase Snap Size

PCB CTRL+R Depend on reference point for copy object repeatly

PCB CTRL+L Open layer manager

PCB CTRL+Q Hide/show network text



DocType Shortcut Function

PCB SHIFT+M Remove All Copper Area fill data

PCB SHIFT+B Rebuild All Copper Area

PCB SHIFT+D Move Object(s) by reference point

PCB SHIFT+G Display track length while routing

PCB SHIFT+W Show favorite track width while routing

PCB SHIFT+R Change routing conflict

PCB SHIFT+S Toggle layers which is not active

PCB SHIFT+Double Click Delete selected track segment

PCB CTRL+SHIFT+V
Paste object(s) and keep the prefix, and hide the
ratline layer

PCB CTRL+SHIFT+SPACE Change routing angle, same as hotkey L

 

 

 

Basic Skills  
To use EasyEDA, you need to be familiar with a few basic terms and concepts. The best way to 
learn them is to open up EasyEDA, open a new schematic:

File > New > Schematic , and play!

Saving Your Work Locally  

Although EasyEDA saves all your files on our Server, sometimes you may want to save your work 
locally and EasyEDA provides a hack way to do this.

You can right-click your project folder, and click "Download Project", or export your design as 
EasyEDA source file via "File > EasyEDA Source".

the more detail you can view at Export EasyEDA Source section.

Or you can download your project.

af://n1372
af://n1375
http://./Export.htm


  

 

Histories Record  

It is easy to use this function, right click on the document for which you need the history in like in 
the image below:
After clicking on the history link, you will get a list of all of the Histories like in the image below.  

Click the History number, you can open the saved file in the editor, if this is what you need, you 
can save it to your project and delete your bad file.

Note:
1. For now all of the Histories are marked as number, we will allow you to add a tag soon.
2. Don't save your files too frequently, or you will get lots of Histories and it will be hard to find the 
exact one you want.

Document Recovery  
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No operating system, software or network is perfect, so sometimes things can go wrong. Having 
your Desktop or web browser freeze or your broadband connection drop, two hours into laying 
out a PCB, could spoil your day.

However, with EasyEDA, your day will be just fine.

This is because EasyEDA auto saves and makes backups of all your open files to your computer 
so crash recovery is built into EasyEDA.

On the top menu, click Menu - Advanced - Document Recovery as below:

Expand the folder to the latest, Select the file which you would like to recover, then click 
the Recover button; your file will be opened in a new tab, then save the opened file.

Please note:  

EasyEDA saves these crash recovery files on your computer and not on the EasyEDA server. 
Therefore you cannot recover files from a crash on one computer or browser by changing to a 
different computer or browser.  
And if you cleaned your browser's cache, the recovery files will disappear.
If you make a mistake to delete a file and remove the cache already, maybe you can find your 
document back via recycle bin: https://easyeda.com/account/user/recycles/personal.

 

Resizing the canvas area  

https://easyeda.com/account/user/recycles/personal
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Hovering the mouse cursor over the areas indicated by the three green ellipses will bring up blue 
sidebar toggle lines. Clicking on them will toggle the visibility of their associated, right and left 
areas to expand the canvas area. The vertical lines can also be dragged horizontally to resize the 
panels.  

  

Cursor Style  

 Some users don't like the cross cursor, so you can change it to arrow cursor like in the image 
below.

Via: Top Menu - View - Cross Cursor 

  

These difference between these options is as below: 

Clear and delete  

If you think your schematic or PCB looks terrible, and you want to redraw all units, you can:
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Top Menu > Edit > Global Delete.

  

Delete this schematic and create a new one.  
Click one object or CTRL+A, press delete key to remove all objects.

Left clicking  

Similar to other EDA software: 

Click on an item to select it;
If over a selected item, click and hold to drag a selected item;
If not over a selected item, clicking and holding while dragging creates a selection box;
the selection box, using click and drag to the right, selects everything inside the box;
the selection box, using click and drag to the left, selects everything inside and intersected 
by the box;
Double click on a text area to edit it;
The exact left click functionality depends on what item is being selected and in what Canvas 
the item exists (Schematic or PCB).

Right clicking  

EasyEDA does not support right click context menus in the Schematic or PCB Canvas. Instead, 
right clicking executes a context sensitive command:

When you are placing a symbol, after a right click, the active symbol will be removed;
When you are drawing a shape such as a polyline, after a right click, the polyline will be 
stopped at the place where you right click but the mouse will remain as a cross, so you can 
draw another shape;
To get out of the current active context sensitive command such as  placement or drawing 
mode and go back to select mode, just double right click.

Ctrl+Right clicking anywhere in the Schematic, waveForm or PCB Canvas drags the canvas 
around within the EasyEDA window.
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ESC key  

Pressing the ESC  key ends the current drawing action but does not exit the current active 
context sensitive command mode (i.e. it does not return the cursor to select mode).

Select more shapes  

CTRL+Left Clicking on items adds those items to your selection;
Clicking and holding creates a selection box;
Creating a selection box, using click and drag to the right, selects everything inside the box;
Creating a selection box, using click and drag to the left, selects everything inside and 
intersected by the box;

Zoom in and Zoom out  

Using the middle mouse button:
Roll forward to zoom in; 
Roll back to zoom out;
Using hotkeys, the default hotkey A  for zoom in, Z  for zoom out.

Please note: 
Do not scroll your mouse at the same time as pressing the CTRL key when your cursor on the top menu, 
the browsers will zoom the whole website, if you just want to zoom the canvas in the EasyEDA window, 
you need to make your cursor into the canvas. If zoom the whole website happens, just 
press  Ctrl+0  to reset the browser view zoom.  

Double clicks  

Double clicking any text area opens a resizable text box to allow you edit the text inline.

  

Press enter to create new line. Click outside the text box to close it.

Pan/Move Canvas  

Right click anywhere in the Schematic, WaveForm or PCB Canvas and Hold down right 
button to drags the canvas around within the EasyEDA window.
If your canvas is bigger than the EasyEDA window and is showing scroll bars, you can use 
either the scroll bars or the Arrow keys to scroll the canvas to pan.
When drawing a wire, a graphic line or shape that you wish to extend beyond the edge of 
the EasyEDA window holding down the left mouse button after starting the line will pan the 
canvas to keep the drawn item inside the window.
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Tip:
If you use Chrome, and cursor is in the canvas while pressing CTRL or ALT key and rolling your mouse, 
the canvas will move vertically, and when pressing SHIFT and rolling your mouse, the canvas will move 
horizontally.

Rotate  

After selecting one or more items, you can rotate the selected items using:

Top Menu > Format > Rotate or by pressing the default rotate hotkey: Space .

  

when in PCB, you can click the footprint and change it's rotation at the right property panel.

Please note:
Rotating a multiple selection rotates each item about its own symbol origin. It does not rotate the items 
about the centroid of the group of items.

Flip  

To place a Q2 as shown in the schematic below you need to Flip the item. Via: Top menu - Format 
- Flip.
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You can Flip one or more selected items using:   

Rotate and Flip > Flip Horizontal or Flip Vertical  from the toolbar,  

or by pressing the default flip hotkeys:  X  to Flip Horizontal, Y  to Flip Vertical.

Notice: Footprint doesn't support to flip.

Align  

EasyEDA provides many align option features, you can align your symbols or footprints very 
easily, Via: Top menu - Format - Align.

  

Bring to Front and Send to Back  

In the image below, both the rectangle and the ellipse are filled. Via: Top menu - Format - 
Bring/Send to Front/Back.

If you draw the ellipse before drawing the rectangle, the rectangle will overlap and therefore hide 
the ellipse. To reveal the ellipse, select the rectangle and then use Bring and Send function, you 
will see:

af://n1500
af://n1504


  

 

Multiple Windows  

Since v6.4.0, EasyEDA supports multiple windows design.

How do it works?

1. Open schematic and PCB
2. Right-click the schematic or PCB tab, click "Open in New Window"

  

3. It will open this document in new window, then you can do the cross probe: Click the 
component, pads, click the Design Manager list, the "Cross Probe and Place" works too.

Documents Tab Switch  

It's easy to fit your documents tab location.  

drag tab location, or use hotkey SHIFT+1, SHIFT+2
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Schematic Capture  
 

During this tutorial we will create a simple Schematic design to guide you in using EasyEDA 
Schematic capture.  

You can find the canvas Properties setting by clicking on any the blank space in the canvas.

As described earlier, background and grid colours and the style, size, visibility and snap 
attributes of the grid can all be configured.

The canvas area can be set directly by the Width and Height or by using the available preset 
frame sizes.

Grid:

Visible Grid : Yes or No
Grid Color: Any valid colour
Grid Style: Line or Dot
Grid Size: To ensure proper alignment of all EasyEDA parts, it is advisable to set in 10, 20, 
100. the unit is pixel.
Grid (and background) colour can be set directly by entering the hexadecimal value of the 
colour you want or by clicking on a colour in the palette that opens when you click on the 
colour value box:
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Snap:

Snap: Yes or No. Pressing this key toggles switching snap to grid on and off.
Snap Size: To ensure proper alignment of all EasyEDA parts, it is advisable to set in 10, 20, 
100 but any valid number can work, such as 1, 5, 10.

It is strongly recommended that you keep Snap = Yes all the time. Once items are placed off-grid 
it can be very difficult to reset them back onto the grid. Off-grid placement can result in wires 
looking as though they are joined when in fact they are not and so causing netlisting errors that 
can be hard to track down.

If you need to draw detailed parts of new symbols or footprints that need to go between grid 
points, try to reduce the grid spacing to draw these elements and then reset the grid back to your 
chosen default value as soon as you have completed that part of the drawing. Setting Snap=No 
should only really be used as a last resort.

ALT Sanp: Snap size when pressing the ALT  key.

 

 

Wiring Tools  
 

If you have hidden your tools , you can open them from here: 
Top toolbar Top Meun > View > Wiring Tools...
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Note: All of the commands in Wiring Tools are electronics related. Don't use a wire when you just need 
to draw a line, shape or an arrow: use Drawing Tools instead.  

 

Wire  

There are three ways to enter the wire mode in EasyEDA.

  

1. Click the Wire button from the Wiring Tools palette.
2. Press the W  hotkey.
3. Click on the end of a component pin (where the grey pin dot appears if you select the 

component): 
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EasyEDA automatically enters Wire mode.

Here is a screenshot of the Astable Multivibrator LED project schematic after wiring:

Moving Components and Wires:

If you place a component, such as a resistor, on top of a wire then the wire breaks and 
reconnects to the ends of the component.

When moving selected components using the mouse, they will drag attached wires with them 
(“rubber band”) to some extent but please be aware that the rubber banding feature has some 
limitations. When moving selected components most wire will move vertically and horizontally. 
Using the arrow keys will not rubber band. Selected wires do not rubber band.

  



A selected wire can be moved directly by clicking on it using the mouse or by the arrow keys. If a 
wire is selected by clicking on it using the mouse then green grab handles will appear at the ends 
and vertices.

Auto adjust connection

If you put a resistor or capacitor on a wire, the wire will auto connect the pins as below:

When you want to wiring a series of resistors which are in a row, you can just wire through them,  
and then you will find they all be connected.

 

Bus  

When you design a professional schematic, perhaps it will use a lot of wires. If you wiring one by 
one, much time would be wasted, and then you need to use Bus .
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Bus Entry  

If you decide to wire with Bus  , the Bus Entry  must connect to Bus and other nets with wires. 
such as in the above image.

  

The "Bus" and "Bus Entry" just for the indication, because when you place Bus and Bus Entry, you 
have to place the netlabel on the Bus Entry dot point.

Net Label  

NetLabel can be used to give your wires names to help you find them and identify any 
misconnections. You can find the NetLabel from the Wiring Tools palette or by using the 
N  hotkey. When selecting the netlabel, you will find its attributes in the right hand 
Properties panel: 
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You can change its name and colour. If you only want to change its name, it may be easier to just 
double click the netlabel.

Multi-NetLabels in One Wire

EasyEDA support mutil-netlabel in one wire now.

When you convert the schematic to the PCB, the editor will choose the first netlabel you placed 
as the net name for this wire, as below NETLABEL1.

Convert to PCB:



As above image, when you click anyone netlabel's name in the design manager, the wire will be 
highlighted. 

And check the bottom right corner, you will see a warning:

  

 

Notice：

If wire 1 has 3 netlabels A  B and C, and wire 2 has netlabel A, then wire 1 and wire 2 are the 
same net.
Netlabel/Netflag/Netport/volprobe only support English characters and letters, and Arabic 
numerals.
If a part prefix is P1, which has two pins, it will have two nets "P1_1" and "P1_2" by default, if you 
place a netlabel named P1_1 at other wire which is not connect with P1 pin1, the default "P1_1" 
will change to "P1_1(1)" for avoid the wrong connection with netlabel "P1_1".

Net Flag  

NetFlag is the same as NetLabel, you can find the NetFlag from the Wiring Tools palette or using 
the  Ctrl+G  hotkeys for GND or  Ctrl+Q  for VCC. You can also change its name, for example 
from +5V to VDD:
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When appear two and more Netflag or Netlabels which are the same name, they will connected 
with each other.

Wiring Tools palette provides NetFlag: Digital GND, Analog GND, VCC and +5V for your 
convenience.

Net Port  

At EasyEDA, Net Port works like Net Label, it doesn't differentiate the input and output net port. 
When you don't want to route too many wires, how about trying  Net Port  :  
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It will make your schematic look more clean, and you just need to set each Net Port a net name.

No Connect Flag  

You can find the NO Connect Flag  via wiring tool,   

In the below schematic, if you don't add a NO Connect Flag , there is an error flag in the nets 
collection of the design manager. 
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And will show the warning:

  

After adding a NO Connect Flag , and then refresh the Nets folder, the error disappears.  

  

Note: NO Connect Flag  only works on the symbol's pin directly.

Voltage Probe  

 

EasyEDA provides a simulation feature for the schematic. After the simulation is running, you will 
see the waveform where you placed the voltage probes in the circuit.
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For more detail about the simulation, please check the Simulation section.

Pin  

When you create a new symbol in schematic and schematic lib, you must use Pin  to create pins 
for the new symbol, otherwise your symbol can't be wired with wires.

For more information please refer to the Symbol Library - Create Symbol section.

Group/Ungroup Symbol  

On the Wiring Tools palette there is the Group/Ungroup Symbol… button.

  

Just like the Symbol Wizard, this tool is also for you to quickly create schematic library symbols.

Here's how.

https://docs.easyeda.com/en/Simulation/Headings/index.html
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Place Pins and other objects such as rectangle

  

Select them, and click the "Group/Ungroup Symbol" icon

  

Type the prefix and name, press OK, done. A part is created.

  

So what does Ungroup do? Try selecting a symbol and then click the Group/ungroup command 
to see what happens!

Note: 



The symbol you created in the schematic will not be saved in the personal libraries, if you 
want to use it repeatly, please create a Symbol via: Top Menu - File - New - Symbol.

 

 

 

 

Drawing Tools  
 

Sheet Setting  

It is now possible to add design notes to the frame and the frame selection, for example A4, 
which can assist in aligning and improve the look of printed schematics and PCB designs. 

Click the frame/drawing/document button like in the image below：

  

And you can edit the blue text when you've selected the text attributes or double clicked it.

The bottom right zone can be selected and dragged or the frame can be dragged and deleted.

When you've selected the bottom right zone, you can edit the sheet attributes:

  

Custom Sheet  
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EasyEDA supports the schematic diagram drawing frame required by custom. At present, custom 
drawings need to be placed manually, and automatic reference of custom drawings is not 
supported when creating new schematic diagram.

How to create:

1. Click the "Sheet Setting" button at "Drawing Tool".

  

2. Click "Add Custom" button.

  

3. It will create a new symbol editor, you can edit the table by line as you want, as below:



4. Select the outline, you can edit its size.

  

5. Save it. You can place it  in schematic such as a part at "Library".

 

Line  

In the Schematic editor, you can draw a line with any direction. You can change its attribute as in 
the image below:

  

Bezier  

With this tool, you can draw a pretty cool pattern.
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Arc  

You can draw the arc of any shape.

   

Arrow Head  

You can add arrow head to marking text or important part.
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Text  

Text attributes provide many parameters for setting:

Text: You can change text in inner box or double click the text. For every new text, the 
default text is Text .
-Color: Defines text color.
-Font-family: It provides 12 fonts for choosing.
-Font-Size: Defines Text size.
-Font-weight: Defines Text weight.
-Font-Style: It contains (auto), normal, italic.
-Text type: types include comment and spice.

The editor will remember your last text parameters. 

  

 

Image  

When you select Image from the Drawing Tools palette, an image place holder will be inserted 
into the canvas:
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Select the place holder, so you can see the image's attributes in the right hand Properties panel:

Set the URL of your image. For example, setting the URL to:

http://upload.wikimedia.org/wikipedia/commons/thumb/c/c7/555_Pinout.svg/220px-
555_Pinout.svg.png

will make your image look like this:

Please note: at present, EasyEDA cannot host images, so you need to upload your images to an 
image sharing site.

Drag  

If you want to move some kind of parts and wires, you can use drag, hotkey D.
Or you can select the parts and wires area firstly and move them.

  

Canvas Origin  

Canvas origin default is set at left top corner of the schematic sheet, but you can set it where you 
want via Canvas Origin.  

For another way to set canvas origin, you can try Top Menu> Place > Canvas Origin.  

http://upload.wikimedia.org/wikipedia/commons/thumb/c/c7/555_Pinout.svg/220px-555_Pinout.svg.png
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Libraries  
 

EELib  

That contains ready made symbols for a wide range of components and which can be simulated.

  

Many of these components have optional US and EU style symbols, we split them, so you can 
select those you like. Click on the drop down list or right click to popup the context menu, it 
contains many footprints or parameters. EasyEDA will remember your choices for the next time.

Don't forget to use Filter to locate a component fastly. For example, you just need to type 0603  
to find all of resistors:
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Library  

EasyEDA provide a lot of libraries, you can find them at "Left-hand Panel - Library", hotkey 
"SHIFT+F", at here you can search library from LCSC, system, user contributed etc.

Type  

Symbol: Schematic symbols
Spice Symbol: Symbols for spice simlation
Footprint: PCB footprints, PCB pattern.
SCH Modules: Schematic modules, a part of the circuit design. It can not assign the PCB 
module, doesn't like the schematic Symbol can assign the footprint . when it be placed on 
the schematic, it will be separated.
PCB Modules: As like as Schematic modules.
3D Model: It is bind with footprint via "3D Model Manager".

Classes  

Work Space: It include your personal parts and your teams' parts.
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LCSC: EasyEDA online part store LCSC.com parts(Officail Parts). It will add new libraries 
everyday
LCSC Assembled: JLCPCB Assembled parts. All JLCPCB assembly parts will contain a SMT 
icon, that means this part can be JLCPCB assemble.
System: EasyEDA system parts, it comes from open source libraries, such as Kicad libraries, 
company public libraries, user contributions.
Follow: If you follow a user at EasyEDA(You can follow a user at him/her user page), you can 
view and use his/her libraries.
User Contributed: When you searching a part, maybe you can find it at this class. At 
EasyEDA, all libraries are public. the detail you can refer at: Contribute

We add an "JLCPCB Assembled" Components option of the Parts, It's easy to choose which 
component can be assembled by JLCPCB. Yes, JLCPCB will provide the assembly service. the more 
information please refer at: How to order a SMT order

 

Search Engine - EasyEDA  

Simply type your part number or symbol's name to Search. before searching, you must choose 
the "Type" first.

and then click the "Table of contents" to open the categories list to choose your components. 

From there you can scroll up and down to browse parts from each category.

If you know the component's name
Suppose you want to find the MAX232 (which converts signals from an RS-232  serial port to 
signals suitable for use in TTL  compatible digital logic circuits). Simply type Max232  into the 
Search box and press Enter:

If you don't know the component's name
For example, you want to find a resistor which value is 1kohm, footprint is 0603, at Libraries 
you can follow below steps:   

1.Choose the library type
2.Typing the keyword such as 1k 0603
3.Click the search button
4.Select the class you which is wanted of the result

https://lcsc.com/
https://easyeda.com/page/contribute
https://jlcpcb.com/smt-assembly
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5.If you don't need the search you need to remove all the search keywords   

Search Engine - LCSC Electronics  

When you want to find some parts by clearly parameter, you should try "Search Engine - LCSC 
Electronics", it all most same as LCSC.com.

When you find out part, and you can place into the schematic:

af://n1812


Notice:

The subpart can not be preview at Preview dialog window, if you find out this, you need to change 
to "Search Engine - EasyEDA" to place this part.

Max and Min mode  
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If you want to place without close the "Library" dialog, you can change dialog mode to Min mode, 
just click the Min button at the top-right corner.

 

Operations  

When you hover the mouse over the picture of the Schematic symbol or PCB footprint, you will 
find a toolbar with "Edit", "Place", "More" buttons.

Place:

For parts you use infrequently, you don't need to Favorite them; just Place it into your canvas 
directly.  Or you can double click the library to place.

Note: 

EasyEDA supports multi-documents so please make sure that you are placing the part into the 
right (active) document. The active document is the one with the highlighted tab.  
You can't place a Schematic symbol into a PCB file, or a PCB Footprint into a schematic.
EasyEDA will try the best to make sure the library is correct, but it still has incorrect parts, if you 
find any incorrect parts please let us known. suggested order a sample first before ordering a big 
order.

Edit:

If you want to create your own version of a symbol or footprint then you can open an existing 
part from the library to use as a template, edit it and then save it to your local Work Space 
library in Library of the Navigation Panel.

More:

We can't promise that every component in the library is free of errors so please check all symbols 
and footprints carefully before you commit to a PCB order.

If you do find a mistake in a component, please use the Report Error , so that we can fix it.

Components with sub parts (multi-device footprints).

When you find a component with sub-parts, you can't Place or Edit it, but you can Favorite and 
Clone it as your own part, which you can then edit.
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Right-Click

When you right-click the part list, you can edit its tags, add favorite etc.

  

Preview Image

Every library when you click, you can check its preview image, such as symbol, footprint, 
production picture. Click the the image you can open it quickly.
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Placing Components  

Find the component which you plan to place to your schematic at "Libraries", then move your 
mouse to the canvas and left click. If you want to add more, just left click again. To end the 
current sequence of placements, right click once or press ESC . 

Don't try to Drag and Drop a component to the canvas EasyEDA team thinks that Click-Click to 
place components will be easier to use than a Click-Drag mode.

 

Multi-part Components  

The number of pins on some components can be quite large. That's why it's easier to divide such 
a component into several parts or functional blocks.

As a simple example, there are six gates in the 74HC04 Hex Inverter component. To avoid clutter 
in the schematic, GND and VCC pins of such components are usually served by a separate part of 
the component. This is really convenient as it doesn't interfere the working process with logical 
parts. The NetLabel names of VCC and GND Pin are usually hidden.

When placing the 74HC04 on a schematic, it will look like the screenshot below.  

Note: The component Prefix will be in form of: U?.1, U?.2 etc.

af://n1851
af://n1855


How to create multi-part(subpart) please refer Create Symbol

Schematic Symbol Wizard  

How many times have you hit a schematic capture roadblock because you couldn't find a 
component symbol?

Well, in EasyEDA that would be never because the Schematic Symbol Wizard provides a quick 
and easy way to create a general schematic library symbol.  

Via: Top Menu > Tools > Symbol Wizard in a new schematic symbol or sheet document.

  

 

The professional function please refer at Schematic Symbol Wizard

 

 

Component Attributes  
 

Component Attributes  

https://docs.easyeda.com/en/SchematicLib/SchLib-Create/index.html
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After selecting a component, you can find the component's attributes in the right hand 
Properties panel.

1.Component Attributes: 

You can change the Prefix and Name here，And make them visible or invisible.
If you want edit this component, you can click Edit Symbol.
 



If the component's property "Convert to PCB" is set as "No", it will not appear at footprint 
manager.

2.Custom Attributes: 

You can change component's supplier, change footprint, and add new parameter.

 

Define BOM Parameters  

After selected a schematic symbol, you can add a parameter, and you can mark it as In BOM , 
when you export a BOM file, you can find this parameter in CSV file.  

 

Modify Symbol Pinmap Information  

When you select a component, for opening the Modify symbol information dialog, you can do:

Or press the I  hotkey;  
Or click the Edit Symbol on the Parts Attributes on the left panel.  
Or click the Symbol and right-click, choose the "Edit Symbol" menu.

Using this dialog you can edit the pin names and numbers, for example, to suit a different 
footprint or device variant. You can also enter a Spice Prefix and swap the spice Pin order to 
make your symbol usable in simulation.   
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More detailed description of PCB and Spice Prefixes and pin numbers at next section.

Prefixes and Pin Numbers  

Device and subcircuit (or hierarchical block) symbols created for use in schematics that are 
intended to be run as spice simulations, in addition to having a PCB Prefix that is used for the 
reference designator in the schematic, also have a Spice Prefix. They also have two sets of pin 
numbers: PCB pins and Spice pins.

PCB Prefix and Spice Prefix  

For more information please refer at Simulation: Schematic symbols: prefixes and pin numbers

 

 

 

Component Adjust  
 

Adjusting Components

About adjusting components you can:

1. Move components with your mouse
2. Move components with the arrow keys.
3. Find components with the Design Manager via the CTRL+D  hotkey: select the component in 

the Design Manager to pan it to the centre of the canvas and then move it with your mouse.
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4. Align the components:

 

Rotating the Prefix and Value (Name) of components

The default Prefix and Value (or name) of EasyEDA components are horizontal. To change them 
to vertical, Left click the prefix or value and when it is highlighted in red color, then press 
the rotation hotkey Space and you're done.

 

 

Components Prefixes  
 

Prefix Start  

In EasyEDA, at the first new schematic the prefix will start as U1/R1..etc, and EasyEDA support 
global unique prefix at multi-sheet now.

Prefix Conflict Error  

Sometimes, if you save a sheet to another project, when you convert a project to PCB, open the 
Design manager or run a simulation, you will get a Prefix Conflict error message.
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In this schematic, you will find two components with the R4 reference designator, so you just 
need to change one to Rx where x is a unique number in that schematic.

It may be tempting to backup a schematic into the same project as the original, however, if an 
attempt is then made to do Convert Project to PCB, you will get the Prefix Conflict error for every 
component.

In the above image, you can find the two identical copies of the same schematic, which when you 
Convert Project to PCB, EasyEDA will try to merge into a single schematic, so every item will have 
2 copies. 
To fix this, you just have to create a backup project and remove or better still save backup copies 
of your schematics to that project.

Annotate  
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After creating a schematic, it is quite likely that you have component Prefixes (reference 
designators) that are in no particular order on the canvas. You may also have duplicates. You can 
automatically renumber/reset all the components' prefix by using the Annotate function.

Via: Top Menu > Edit > Annotate

Various Annotate possibilities are available:

Re-annotate all: resets all existing annotation and then annotates all components again 
from scratch;
Keep existing annotation: annotates new components only (i.e. those whose reference 
designator finishes with ? like R? or U?).
Direction: Rows annotates across the schematic in a raster pattern from top left to bottom 
right; 
Cols annotates down the schematic in a raster pattern from top left to bottom right.
Annotate: applies the selected annotation actions. 
Reset: if you want to reset all the reference designators to end with '?', just click 
the Reset button. After that, R1 will be R?, U1 will be U? etc.

Note: 

Reset does not reset annotation back to where it was before pressing the Annotate button.
Annotation cannot be undone! if you do not accept the result: close all of the affected 
schematics without saving. If you do accept the result: make sure you save all of the affected 
schematics.

 

 

Multi-Sheet  
 

EasyEDA does not support true hierarchical designs but it does support multi-sheet designs. 
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You can put several schematics in one project with connections between made 
by NetLabels/netPorts. All nets in EasyEDA are global so if you create a netlabel  DATA0  in sheet A 
and then create a netlabel  DATA0  in sheet B, when sheet A and sheet B are in the same project, 
they will be connected.

  

Multi-sheet designs(equivalent to a circuit spread over several pieces of paper), all schematics 
under the same project will be merged into one when be converted to PCB connecting in 
Netlabel, Netflag, Netport.

  



You can click the Sheet tabs on the left-down corner to switch the Sheets, and right-click the 
sheet tab you can "Save as", check "Histories record", "Move Forward/Backward","Rename" and 
"Delete" the sheet.

  

If you want to arrangement the sheets order, you click the menu of the sheet icon: Move 
Forward/Move Backward.

Note: 
EasyEDA support global unique prefixes, when you place components in different sheet, the editor will 
auto annotate the prefix. If you save as a sheet to another project, please make all of the prefixes 
unique, if the Sheet A has a R1, and the Sheet B has a R1, then you will get a Prefix Conflict Error.

 

 

Design Manager  
 

With large schematics it can be hard to find the components quickly. Sometimes, you may make 
a mistake such as wiring to a wrong component pin. So you need a tool to help you out. Design 
Manager is just the tool.
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Just press the CTRL+D  hotkey to open the Design Manager.
or click it via on the left navigation panel:

1. Filter: You can find your components or net name easily: for example, if you want to find 
all capacitances, you just need to type C ;

2. Components: Lists all the components in this schematic. Clicking on a Component item 
highlights that component and pans it to the center of the window.

3. Nets: Lists all the nets in this schematic. A net must connect at least two Pins, or the net 
name will be marked as a red error. When click the net name, the canvas wire will highlight 



and being large, when you click the empty space to unhighlight:  

4. Net Pins/Parts Pins: Lists all the pins of the selected net name or components.

 

 

 

 

Footprint Manager  

Introduction  

Want to batch modify components? Can't identify the corresponding relationship between 
component pins and footprint pins? Don't worry, EasyEDA can do this.

There are two ways to open the footprint manager:
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Click top menu, via: Top Menu - Tools - Footprint Manager

  

Click the footprint input box of custom attributes when you've selected a component:

  

 

1. Footprint manager will check your parts footprint correct or not automatically when open it.  

If the part without the footprint or this footprint doesn't exist in EasyEDA Libraries, or if the part's 
Pins doesn't correspond the footprint's Pads correctly, the footprint manager will show the red 
background alert.   

For example, If your part D1 has 2 pins, 

pin numbers are 1  and 2 , 
pin names are A  and C ,

 but you assigned a footprint has 2 pads, 

pad number are A  and C , 

https://docs.easyeda.com/en/PCB/PCB-Tools/index.html#Pad


 but the part's pin number doesn't match the pad number, so the the footprint manager will alert 
red background:

In order to solve this:

method 1: change part's pin number from 1 and 2 to A and C.
method 2: change footprint's pad number as 1 and 2. That needs the footprint is created by 
you. And you can't change the Pad number in footprint manager, you need to find out the 
footprint at "Library > Footprints > Work Space", and then edit it.
method 3: find an other footprint and update.  

2. In the preview area, you can zoom in, zoom out and pan with mouse scroll button.

Component PIN Information: And you can modify component's pin map information in 
here. 

PCB PAD Information: 

https://docs.easyeda.com/en/Schematic/Component-Attributes/index.html#Modify-Symbol-Pinmap-Information


Pad Number: You can check the footprint's pad number, but you can't modify it. when 
you select the component on the left side, it shows component's footprint pad number, 
if you selected a footprint which is searched or selected from the classes, it will show 
the selected footprint's pad number.
Pad Size: You can check the footprint's pads size and distance, it same as "Check 
Dimension" tool of footprint editor. Click the preview area unit text to change size unit.

Update footprint  

If you want to change the footprint, for example, select a component such as Q1, from TO-
92 TO TO-220, you just need to click in the footprint input box. EasyEDA will popup the footprint 
manager dialog. You can follow the instructions. 

Type TO-220 into the search box and search, Or change to Select tab,   
Select the classes you want and select TO-220 footprint,   
Verify it in the preview box,  
then press the Update button.   

After that you will find you have changed the footprint to TO-220.

Note: 

To ensure that you use a footprint type that is already in the EasyEDA library, it is recommended 
that you use this technique to change component footprints rather than just typing a footprint 
name directly into the footprint text input box.because of the footprint manager will add the 
footprint's global unique ID into the schematic when the footprint updating.

When you select a subpart, the others subparts will be selected too, so they will update the 
footprint together.
If the part's property "Convert to PCB" is set as "No", it will not appear at footprint manager.

Update in Batch  

If you want to batch modify components' footprints, 
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In the footprint manager dialog, you can press CTRL + click  or SHIFT + select  to select 
the components, and then select the footprint to update.
In schematic canvas, you can frame select the commponents as you want, and then click the 
"footprint" attribute input box at the right-hand property panel.

To use your own footprints, you can select Work Space under the Select tab.

  

 

 

 

Find Similar Objects  

Find Components in the Schematic  

Finding individual components in a dense schematic can be very time consuming. EasyEDA has 
an easy way to find and jump to components:

Top Menu> Edit > Find…

(or Ctrl+F )

Note: You have to click OK?in this dialog or use the Enter key.

This feature will find, highlight and center in the window, parts by their Prefix (or reference 
designator). However, it cannot be used to find net names or other text in a schematic.
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This is where the Design Manager comes in. the more information please refer Design Manager 
chapter.

Find Similar Objects  

EasyEDA provide a powerful find similar tool, you can find what you want very easily.
Via Top Menu > Edit > Find Similar Objects…

Kind: Select the object what you want to find.
Range: This option only for the schematic, you can find the object for current sheet or all sheets.
Find Parameters: Any: Find any objects; Same: Only find the object which attribute same as this 
attribute. Different: Find the object which attribute is different than this attribute.
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The input box support the Js Regular Expression, you can type /keyword/  to find what you want, 
such as find all prefix which are including "R": 

After click the "Find" button, all the siutable objects will be seleted, and the right-hand panel will 
show all the attributes, the different attributes will show as the <...> , you can change the 
attributes directly, and they will apply to all selected objects.

The find similar objects only support to find a part of custom attributes. Such as footprint, 
suppiler etc.

 

Convert Schematics to PCB  
 

Convert to PCB  

Most of the time, schematics are created with the aim of producing a PCB. So how do you convert 
your schematic to a PCB in EasyEDA? You just need to to click the PCB icon on the toolbar with 
the title Convert to PCB.  

  

Note: 

Before converting, you need to use the Design Manager and Footprint Manager to check all the 
components, nets(connection) and footprints to ensure no errors exist.
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Footprints Verification  

After clicking the Convert to PCB button, if the project has errors the following dialog will open:

  

The row in red indicates that EasyEDA can't find a PCB footprint matching the footprint that the 
schematic symbol is calling for.   

This could be because you have made an error entering the footprint attribute in the symbol's 
Properties or maybe you haven't yet created a PCB footprint for the footprint that your symbol is 
calling for.   

In this case the footprint should have been AXIAL-0.3 but instead it is empty. To correct it you 
can click on the row and update the footprint AXIAL-0.3 for it at the footprint manager.

After making any necessary corrections, click the Convert to PCB button and EasyEDA will 
automatically load all the PCB footprints into the PCB editor as shown in the image below.
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This shows the footprints placed in arbitrary positions with the connections between them 
shown as blue Rat lines.

Invalid footprint  

The footprint's PAD number is different from the symbol's PIN number, e.g. the diode footprint's 
PAD numbers are A,C but the symbol's PIN numbers are 1,2. You just need to change one to fit 
the other. It is case sensitive!

 

the changing method please refer the Schematic - Footprint Manager section.

Update PCB  

Converting a schematic to PCB can be done using the Convert to PCB...  , but if you do 
modifications to the schematic, by using the Update PCB  button you can immediately be passed 
forward to update the selected PCB without having the PCB editor window already open or 
without creating a new PCB file. 

  

or you can use "Top Menu - Design - Import Changes" at PCB editor.
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Cross Probe  
 

This tool is used to cross probe from chosen objects on the current schematic to its 
corresponding counterparts in the PCB, or from PCB Footprints to corresponding counterparts in 
the schematic. 

  

Since v6.4.0, EasyEDA supports multiple windows design to cross probe.

How do it works?

1. Open schematic and PCB
2. Right-click the schematic or PCB tab, click "Open in New Window"

  

3. It will open this document in new window, then you can do the cross probe: Click the 
component, click the Design Manager list, the "Cross Probe and Place" works too.

Note: 

You need to open PCB first before using cross probe in the schematic. And don't forget to use the 
hotkey SHIFT+X .  
After converting the schematic to PCB, for using this function please save the PCB first.
If your project has many PCBs, when you use the cross probe please open the PCB what you need 
manually.

 

 

Cross Probe And Place  
 

If your schematic have a lot of components, it will be difficult to layout the PCB , so EasyEDA 
provides a powerful function "Cross Probe And Place".

Top Menu> Tools > Cross Probe And Place
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Cross Probe And Place will make the footprints' location match the schematic's parts' location as 
much as it possibly can.

How to use: 

Convert the schematic to PCB first, and save at current project.
Frame select the components area by mouse in the schematic, and then click the "Cross 
Probe And Place", hotkey "CTRL + SHIFT + X".
The editor will switch to the PCB, and choose the footprints as you selected for waiting for 
placing.
Right click to place, and the mouse will keep the drag status, its easy for adjusting the 
footprints' location.

Notice:

You need to open PCB first before using this function in the schematic  

 

 

Global Delete  
 

If you feel your schematic or PCB is mess up, need delete objects in batch, you can:
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Top Menu > Edit > Clear All，or CTRL + A select all and then press Delete key.

  

Delete the document and create a new one.

  



Using Top Menu > Edit > Global Delete, just delete what you want. 

 

 

 

Schematic Modules  
 

Copying codes is an easy job for coders, now copying and reusing a schematic or PCB is easy.
Take a power supply unit for example, you can save this unit as a schematic module.
Via File > Save as Module:
EasyEDA support create the PCB modules, it seems schematic module.

How to Create  

Via: Save as Module and File > New > Schematic/PCB Module。
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PCB module save at Library > Schematic/PCB module > Work Space > My Libraries

 

How to use  

Since v6.4.3, after placing schematic modules and PCB modules, after Import Changes, supports 
to keep the layout location.

How to use:

1. Draw schematic modules and PCB modules, and ensure that their component prefix are 
one to one, and the footprint is also corresponding. The module's component prefix can not 
have question marks and duplicate prefix, such as U? or two R1.

2. Open schematic and PCB at a same project.
3. Open "Library", select the module.
4. Click the "Place" button to place the previous saved schematic module and PCB module.
5. It will pop up a window to enter English letter.  The letter of schematic module should keep 

corresponding with  PCB modules.

For example: A component at schematic module is U2, enter letter K, press OK to place into 
canvas, it will be KU2, then PCB module has KU2 too.
Click "OK" and enter the placement mode. After each placement, the pop-up will continue to 
enter the identification letter. Make sure that the identification letters entered each time are 
unique.

6. When finish the module place, the PCB component unique ID will same as Schematic 
component unique ID, then after Import Changes, the component's location will be keep. 
and you can update the track's net follow the schematic netlabel too.
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That implement the multipe chanel placing.

Notice:

Module composes by tracks and components, it doesn't same as symbol binding footprint, 
the schematic module can not binding PCB module, after placing, the module will be 
separated by many objects, only the symbol and footprint can be corresponding via 
component ID, that is why you need to make the identication letter unique for placing each 
time to make sure schematic module corresponding with PCB module.

 

 

                     

Schematic Theme  
EasyEDA support a powerful theme feature for the schematic design.

Via: Top Menu - View - Theme.

  

Original Theme：The default theme, only works for the new part placing.

White on Black：White on Black, the objects will be white, the background will be black.
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Black on White：Black on White.

User Definded：When change to this theme style, the schematic will follow your theme options 
"My theme".

My Theme：Custom theme, which is stored locally in the browser and it will be synchronized to 
the server. When click apply, this theme will be applied to the current schematic. Next time you 
open the schematic, the theme of the schematic will be a custom theme.

My theme Settings：You can apply "My theme" on: 1. Creating New Schematic, 2.Opening 
Existed Schematic.

If you used any theme for the schematic, you need to UNDO to go back previous color theme. 
The "Original Theme" can't help.

Your schematic theme will synchronized to the server by default.  

 

 

 

                     

Export BOM  
 

You can export the Bill of Materials (BOM) for the schematic (Document) and PCB, via: "Top Menu 
- File - Export BOM", or "Top Menu - Fabriaction - BOM".

  

After clicking the BOM export option, the dialog below will open.

In this dialog，you can click the buttom to assign LCSC part's order code for your components.
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After clicking on the assign icon，the components and footprints search dialog will pop up, and 
you can choose which component you want to assign.



When you click the "Order Parts/Check Stock" button, we will help you to list all the components 
of your BOM at LCSC.com(If you haven't login LCSC, you have to login first). If you want to buy the 
components form LCSC, and you just need to put them to the cart and check out.

You can open the BOM in any text editor or spreadsheet.

Notice:

If your project has schematic and PCB, the BOM data will come from schematic; if the 
project only has PCB, the BOM data will come from PCB.
In order to support multiple languages, BOM and coordinate files (CSV file) are UNICODE 
encoded and tab-based. If the CSV file cannot be read by your components vendor or PCB 
manufacturer, please convert the encoding and change the delimiter.
Recommended solution: Save as a new CSV file in Excel or WPS. For example, open a CSV file 
in Excel, click or select: Save As - Other Formats - CSV (Comma Separated) (*. csv).
You can also open the CSV file with any text editor (such as Windows Notepad) and save as 
ANSI or UTF-8 encoding. If necessary, replace all tabs with commas.

 

 

Export NetList  
EasyEDA can export the netlist for the whole active project:

File > Export NetList > Spice...

af://n2258


  

EasyEDA can export a netlist in a variety of formats: 

LTSpice for this Sheet: this is a Spice compatible netlist generated by the simulation engine 
of EasyEDA, It is not normally used as the basis for as a PCB layout.
Protel/Altium for PCB: a PCB netlist in a format that can be imported straight into Altium 
Designer and it's predecessor, Protel. 
PADS for PCB: a PCB netlist in a format that can be imported straight into Pads PCB layout 
tools.
FreePCB for PCB: a PCB netlist in a format that can be imported straight into FreePCB, a 
 free, open source PCB editor for Windows.

 

 

 

Report Error  
For EasyEDA official libraries, we have staffs to draw and maintain(LCSC & JLCPCB Assembled 
part) and we will try to keep them correctly as we can, but EasyEDA(System part) included a lot of 
open source of the libraries and the official drawing of the libraries, that can not avoid the wrong 
situation 100%, so when you meet a incorrect library, Please inform us in time, we will fix it as 
soon as possible.

There are 3 ways to report error:
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1.Right-click the offical library and use the "Report Error" function on the "Libraries".

2.Select the offical library on the canvas of the schematic/schematic module, click the "Report 
Error" button at the right-hand panel.

  



or right-click the component:

  

3.Send Email to us or post a topic at Bug report

  

 

                    #  Create the Schematic Symbol

Create the Schematic Symbol  

Using Schematic Symbol Wizard and Group/Ungroup... is a quick way to create schematic 
symbols but they are placed directly into the schematic that they are built in. 

It is possible to reuse them by copying them ( CTRL+C  hotkeys) from the schematic they were 
created in and then cross-document-pasting them ( CTRL+SHIFT+V  hotkeys) into a different 
schematic but this quickly gets messy if you need to copy symbols that were created in several 
different schematics. 

OK, you could keep copying new symbols into a dedicated “symbol library” schematic sheet to 
save searching for them but EasyEDA offers you an easier way to create and manage your 
symbols in a library.

Start a new Schematic Lib as shown below or by doing:

https://easyeda.com/forum/category/2
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1. File > New > Symbol 

 

This opens the New SchematicLib symbol editor.

2. Create the symbol

Get the Datasheet 
For example, using the NE555DR, the datasheet you can refer LCSC: NE555DR.
And then create the symbol and place the pins for the library base on the datasheet. 
This component have 8 pins and names. 

Create via Schematic Symbol Wizard 

 

The more information of Schematic Symbol Wizard please refer next section.

Create by Manually

https://datasheet.lcsc.com/szlcsc/NE555DR_C7593.pdf


Draw the shape via the Drawing Tools

 

Place the Pins

 
The Pin dot must keep out side as the image indicated, it is connecting with the wires. 
The more information please refer SchematicLib Attributes - Pins Section.



3. Edit the pin map
Via Edit > Pin Map..., change Pin names and Pin numbers. For some complicated IC, will use the 
alphabet for the pin number. 

4. Modify the Detail
such as change Pin length, place text, change Pin color, Pin attributes etc.

5. Set Costom Attributes
You can set the supplier, footprint(Suggested, you must assign the footprint via "Footprint 
Manager"), Name(Required), Prefix(Required) for it, the more detail of attributes please refer 
below section: Custom Attributes



If the schematiclib need to assign the packahe, the Pin number should match the footprint's Pad 
number. The detail of the footprint assign please refer the Footprint Manager section at 
previous.

If the part's property "Convert to PCB" is set as "No", it will not appear at footprint manager.

6. Set the Origin
You can via: "Top Menu - Place - Set Canvas Origin - By Center Grid of Symbols" to set the origin.

7. Save your SchameticLib
You can set this library's owner, datasheet link and tags etc. 



Then a Schematic Symbol is created finish. And the you can find it at "Libraries - SchematicLib - 
Personl" on the left-hand.

Notice:

Note the Origin Point. To simplify rotating your symbols when they are placed into the 
canvas, make sure all of your symbols are created as near as possible centered around that 
point. Suggesting the first Pin/Pad or its center to be the origin point. 
Please make sure all pins dot are placed on the grid, otherwise, when place the library on the 
schematic will causing the wiring difficult.

 

Pin Attributes  

Symbols pins are the most important part of any Schematic Lib symbol. They are the things that 
allow wires to be attached to symbols to connect up your circuit.

You can use the P hotkey to add a Pin or from the Draw Tools pallete:

Before placing it on the canvas, you can use the rotation hotkey or rotate and flip from the menu 
to rotate it to the right orientation. Make sure the Pin Dot(black dot) is in the right position. The 
Pin Dot will be used to connect your wires or netlabels. Whenever a PIN is either placed as 
directly onto the canvas or as part of a symbol, the mouse has to point to the Pin Dot position to 
automatically start the Wire mode or to join a wire to it.
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Whenever a Pin is placed as part of a symbol, the Pin dot should be outside of — and pointing 
away from — the symbol like in example 1(correct position), inside or pointing towards 
the symbol as shown in example 2(wrong position).

When you select a single Pin, the Pin attributes will be shown in the right hand Properties 
panel:



Orientation: 0°,90°, 180° and 270°。If you want to create a 45° pin, you need to set it length as 
0, and draw a line with 45°。

Start-X and Start-Y: The pindot position. Sometimes it may be difficult to move the pin to the 
desired position using the mouse, so you can move the pin via Start-X and Start-Y.

Length: Pin length.

Name: In this example, VCC is the name of the Pin.

Number: In this example, 1 is the number of the Pin. This number is the pin number of the 
device in a physical footprint.

Note that you can use alphanumeric identifiers such as; A1, B1, C1, A2, B2 and so on as the 
Number.

Spice Number: These are the pin numbers used to connect your symbol to the corresponding 
pins defined by the .model or .subckt used to simulate your device. The pin numbers of the 
simulation model may be different from the physical footprint pin numbers and - unless the 
model is specifically created to model multiple devices in a single footprint - do not change for 
different instances of a device in a multi-device footprint. The Spice Pin order must be numerals 
only.

Name Display: If you don't want to show VCC, switch it to NO.

Number Display: If you don't want to show 1, switch it to NO.



You can adjust the Name or Number position using your mouse but note that rotate and flip 
applies to the whole pin including the name and pin number; these items cannot be rotated and 
flipped independently of the pin itself.

Note also that rotate and flip actions do not result in upside down or mirrored pin number or 
names.

Color: You can set the Pin to different colours, such as PIN3:CLK as orange and PIN4:GND as blue. 
In this example, the PIN1 is set as color #880000 , but it shows as red, because it is selected. After 
deselecting it, the pin will appear color #880000 .

Dot: adds a circle to the inside end of the pin to indicate logical (or analogue) inversion.

Clk: adds a >  to the inside end of the pin to indicate that the pin is logical clock input.  

Show: YES/NO. Allows you to hide the pin. When set it to NO, this Pin will be hidden when the 
symbol is placed on the schematic editor canvas, and then create a net which name same as this 
pin name.

Note that the pin is not hidden here in the Schematic Lib symbol editor canvas because if it was, 
it would disappear from view and so how would you find it to make it visible again? For the same 
reason this option has no effect in symbols made using Group/Ungroup…

We may not have thought of everything in EasyEDA but we do try.  :)

Electric: [Undefined, Input, Output, I/O, Power] 

EasyEDA provides Electrical Rules Checking (ERC) right now, But you still need to set electric of 
your Schematic libs. 



If you set the PIN as Power and set the pin to be hidden, then the Pin will be connected by 
Name which is the NetLabel. If the Name is VCC, it will be connected to the net in your circuit with 
the NetLabel or NetFlag VCC. This is helps to keep the schematic clear and uncluttered when 
using Multi-part Components.

After created the Lib, use  CTRL+S  will open the save dialog:

After clicking Save, you will see it appears in Libraries > Symbols > Personal of the left hand 
Navigation panel.



If you want to modify the tag for your new symbol: Libraries > Symbols > Personal > Select 
New Lib > More > Modify, or right-click new Lib > Modify, if your Lib doesn't have the tags it 
will appears on All.

 

Custom Attributes  

In the Schematic Lib editor's canvas Properties panel, you will find a Custom Attributes section:

 

footprint

How to change Schematic Symbol's footprint? If you would like to built a PCB, you need to assign 
a footprint for your Schematic symbol. Although there are other ways to do this in EasyEDA, here 
is the right place to do it. When you set a footprint , the footprint's pad numbers must match 
the  schematic Lib's pin number, otherwise,  when you convert the schematic to PCB , there will 
miss several nets.

Click in the footprint input box, and the  Footprint Manager dialog will open as used to do this 
task in the Schematic Editor.

The more information please refer to Schematic - Footprint Manager section.

Notie: 
You have to assign the footprint via the Footprint Manager, otherwise, the Schematic lib will not get the 
footprint correctly. The footprint is linked with SchematicLib by global unique ID not the title.

Prefix

The default Schematic symbol Prefix is U? If you create a resistor, you can set the Prefix to R?. It is 
filled required. 

Name
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You can change the schematic lib's name here, it is can be different from the part's file name.

Contributor

This is your registered user name. When Other EasyEDA's users use your libraries, they will 
remember your contributions!  

 

Symbol Subparts  
 

We have already touched on how EasyEDA can support Multi-part/Subpart Components , but 
how do you create multi-part components?

EasyEDA provides a sub parts facility to do this.

After creating a part, you can right-click the part in the Library > Symbols > Work Space > 
Created section to pop up the content menu.

Suppose you have created your own symbol for a 74HCT04 hex inverter.

Right Click Add sub part and that will add 74HCT04.1,  

Click again to add 74HCT04.2 , up to 74HCT04.6. 

Then double click on each sub part in turn to modify the Pin Name and Number attributes.

Easy or what?

 

Schematic Symbol Attributes  
 

Pin Attributes  

Symbols pins are the most important part of any Schematic Lib symbol. They are the things that 
allow wires to be attached to symbols to connect up your circuit.

You can use the P hotkey to add a Pin or from the Draw Tools pallete:
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Pin Orientation  

Before placing it on the canvas, you can use the rotation hotkey or rotate and flip from the menu 
to rotate it to the right orientation. Make sure the Pin Dot(black dot) is in the right position. The 
Pin Dot will be used to connect your wires or netlabels. Whenever a PIN is either placed as 
directly onto the canvas or as part of a symbol, the mouse has to point to the Pin Dot position to 
automatically start the Wire mode or to join a wire to it.

Whenever a Pin is placed as part of a symbol, the Pin dot should be outside of — and pointing 
away from — the symbol like in example 1(correct position), inside or pointing towards 
the symbol as shown in example 2(wrong position).

Pin Attributes  

When you select a single Pin, the Pin attributes will be shown in the right hand Properties 
panel:
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Orientation: 0°,90°, 180° and 270°。If you want to create a 45° pin, you need to set it length as 
0, and draw a line with 45°。

Start-X and Start-Y: The pindot position. Sometimes it may be difficult to move the pin to the 
desired position using the mouse, so you can move the pin via Start-X and Start-Y.

Length: Pin length.

Name: In this example, VCC is the name of the Pin.

Number: In this example, 1 is the number of the Pin. This number is the pin number of the 
device in a physical footprint

Note that you can use alphanumeric identifiers such as; A1, B1, C1, A2, B2 and so on as the 
Number.

Spice Number: These are the pin numbers used to connect your symbol to the corresponding 
pins defined by the .model or .subckt used to simulate your device. The pin numbers of the 
simulation model may be different from the physical footprint pin numbers and - unless the 
model is specifically created to model multiple devices in a single footprint - do not change for 
different instances of a device in a multi-device footprint. The Spice Pin order must be numerals 
only.

Display Name: If you don't want to show VCC, switch it to NO.

Display Number: If you don't want to show 1, switch it to NO.



You can adjust the Name or Number position using your mouse but note that rotate and flip 
applies to the whole pin including the name and pin number; these items cannot be rotated and 
flipped independently of the pin itself.

Note also that rotate and flip actions do not result in upside down or mirrored pin number or 
names.

Color: You can set the Pin to different colours, such as PIN3:CLK as orange and PIN4:GND as blue. 
In this example, the PIN1 is set as color #880000 , but it shows as red, because it is selected. After 
deselecting it, the pin will appear color #880000 .

Dot: adds a circle to the inside end of the pin to indicate logical (or analogue) inversion.

Clock: adds a >  to the inside end of the pin to indicate that the pin is logical clock input.  

Show: YES/NO. Allows you to hide the pin. When set it to NO, this Pin will be hidden when the 
symbol is placed on the schematic editor canvas.

Note that the pin is not hidden here in the Schematic Lib symbol editor canvas because if it was, 
it would disappear from view and so how would you find it to make it visible again? For the same 
reason this option has no effect in symbols made using Group/Ungroup…

We may not have thought of everything in EasyEDA but we do try.  :)

Electric: [Undefined, Input, Output, I/O, Power] 

EasyEDA provides Electrical Rules Checking (ERC) right now, But you still need to set electric of 
your Schematic libs. 

If you set the PIN as Power and set the pin to be hidden, then the Pin will be connected by 
Name which is the NetLabel. If the Name is VCC, it will be connected to the net in your circuit with 
the NetLabel or NetFlag VCC. This is helps to keep the schematic clear and uncluttered when 
using Multi-part Components.

After created the Lib, use  CTRL+S  will open the save dialog:



After clicking Save, you will see it appears in Libraries > Symbols > Personal of the left hand 
Navigation panel.

If you want to modify the tag for your new symbol: Libraries > Symbols > Personal > Select 
New Lib > More > Modify, or right-click new Lib > Modify, if your Lib doesn't have the tags it 
will appears on All.



 

Symbol Custom Attributes  

In the Schematic Lib editor's canvas Properties panel, you will find a Custom Attributes section:

Add into BOM
This part display at BOM or not.
Convert to PCB
If you set it as No, this part will not display at Footprint Manager and can't not convert to 
PCB.
footprint
To assign a footprint for this part. Only assign one footprint.
The more information please refer to Schematic - Footprint Manager section.
Notie: 
You have to assign the footprint via the Footprint Manager, otherwise, the Schematic Symbol will 
not corresponding the Footprint correctly. The Footprint is linked with Symbol by global unique ID 
not the title.
Pre
The default Schematic symbol Prefix is U? If you create a resistor, you can set the Prefix to 
R?. It is filled required. 
Name
You can change the schematic lib's name here, it is can be different from the part's file 
name.
Contributor
This is your registered user name. When Other EasyEDA's users use your libraries, they will 
remember your contributions!  

Show symbol value as component name when place
component at schematic

 

For example, a resistor symbol vaule is 2KΩ, name is ABC, but when place it at schematic, it will 
not show 2KΩ as component name, the name is ABC. You can change name to 2KΩ, but it not 
very well.
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EasyEDA doesn't support common function to support this feature yet.

But, we can edit the symbol file soure to implement this feature.

How do it works:

1. Finish symbol and parameter edit.
2. Open file source. via: Top Menu - File - EasyEDA File Source.

  

3. Add or modify the parameter: nameAlias.

  

This symbol will show 1k as component name after placing at schematic.

4. Apply after modified, and save.

You can double click the EElib resistor symbol to get an example.

EasyEDA will provide it as a feature in the future.

Schematic Symbol Wizard  
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How many times have you hit a schematic capture roadblock because you couldn't find 
a component symbol?

Well, in EasyEDA that would be never because the Schematic Symbol Wizard provides a quick 
and easy way to create a general Schematic Symbol symbol.   

Via: Top Menu - Tools - Symbol Wizard

  

Basic Function  

Input the Pins' name Only  

1. Using the NE555 timer as an example: this device is available in a DIP8 package so select 
DIP. Then enter the NE555 pin names into the Pin Names text box separated by new line or 
space, Then press OK. Abracadabra! As if by magic, you will find a perfectly formed dual in 
line 8 pin symbol for the NE555 attached to your mouse cursor, ready to be placed! You just 
need a few seconds to build a NE555 symbol, quickly and easily.

2. The EasyEDA Schematic Symbol Wizard allows you to create DIP, QPF or SIP styles symbols. 
If you are designing Arduino Shields then you will need lots of SIP symbol, so you can create 
a SIP symbol like the one shown below in a few seconds.
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3. If you are not too worried that the symbols may not look quite the way people might expect 
and that they may not look anything like the Type you select, then of course you can use the 
wizard to create symbols for any component:

Input the Pins' number and name  

Schematic Symbol wizard support you input the pins' number and name.
As below example, setting every pin's number is easily.

 

Professional Function  

Schematic Symbol Wizard support the professional function, it is easier to create the large and 
complex and more convenient Schematic Symbol.

1.Download Schematic Symbol Wizard Template.xlsx

2.Open it via Excel or WPS, and edit each Pins attributes and position, and then copy the content 
and paste in wizard dialog without content title. 
Tip: If you want to create the gap between Pin and Pin, you can use the *  as below image.
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3.The Wizard will create the symbol follow your content. The types you chosen will be ignored.

 

Notice:

If the content you input wasn't one, two or eight columns, it will shown incorrect format.  
You can use the Key Space to separate the column data.

 

 

Edit Exited Schematic Symbol  

Personal Libraries  

When you CTRL+S  to save the Schematic Symbol, will pop up a dialog, you can choose this 
library's owner:
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After finish, you can find your library at the left panel: Library > Symbols > Work Space > All

Tag

When you select it , right-click it and select the menu "modify", you can add a tag for it.



Favorite

When you favorite a library, you can find it at Library > Symbols > Work Spacel > Favorite  , If 
this library has a tag, the tag will show up too, but you can't edit that.
But you can via "Clone" or "Edit and save" to create a new library to personal libraries.                   

  

 

Edit Symbol in the Library  

When you feel the Schematic Libs can not be satisfied for you, you can edit it.

Via "Library" > "Search Part/Work Space/LCSC/System" > Select Symbol > Edit

or you can click the preview image
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when you finish and save, it will be saved to your personal libraries Work Space and become 
your personal libraries.

Edit Symbol in the Schematic  

If you want to edit a symbol in the schematic, you can use the Ungroup/Group function.

On the Wiring Tools palette there is the Group/Ungroup Symbol… button.

  

This tool is for you to quickly create or edit schematic library symbols.

1. Select a symbol
2. Click the Group/Ungroup Symbol… button

Up to this point you have a collection of separate pins, a drawn rectangle and some text that 
are all separate items with no particular association with each other.

3. Edit the shape or pin what you want to change
4. Select all of the items and click the Group/Ungroup Symbol… button. 

A dialog will be opened:
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After you click OK, all those separate elements will be grouped together to form your new symbol 
directly in the schematic.

Using the group function, you can create/edit any symbol in the schematic, easily and quickly.

 

 

 

Canvas Setting  
 

After the initial conversion of a schematic to PCB, it is time to learn how to manage EasyEDA's 
PCB Design Editor.

Canvas Attributes

Lots of PCB canvas attributes are the same as Schematic canvas attributes. The key is that you 
can set units in PCB canvas attributes.
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When you select a object at the canvas, you can modify its attributes at the right panel.

Snap Size: The cursor snapping size.
Alt Snap: When press hotkey ALT the cursor snapping size.
Other

Routing Width: Setting the default routing width.

Routing Angle: Setting the routing angle.

Routing Conflict: When routing the track, what to do when impact the difference net 
objects.

Ignore: The track go through the objects.
Block: The track will stop when meet the difference net objects.
RoundTrack: The track will go aroud the difference net objects.

Remove Loop: Remove the track loop.

Copper Zone: Setting the copper zone visible or invisible.

 

PCB Tools  
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PCB tools provide many function to fulfill your PCB design requirement.
Such as: Track, Pad, Via, Text, Arc, Circle, Move, Hole, Image, Canvas Origin, Connect Pad to Pad, 
Copper Area, Solid Region, Measure/Dimension, Rect, Group/Ungroup. etc.

  

 

Track  

In the schematic editor, we use Wire or the W  Hotkey to connect Pins, in a similar way in the PCB 
editor, we use Track to connect Pads. Track allows you to draw PCB tracks and can be found on 
the PCB Tools palette or using the W  Hotkey (not T: see above!).

  

When a track is selected, you can find its Length attribute in the right panel.
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If you want to create solder mask for the track, you can click the "Expose Copper" button at the 
right-hand property panel.

The more information of routing, please refer at PCB: Route Tracks

 

Pad  

You can add pads using the Pads button from the Footprint Tools palette or using the P  hotkey.

  

After selecting one of the pads, you can view and adjust its attributes in the right hand 
Properties panel.

Number: Remembering the pin numbers you set in the schematic symbol in your Schematic 
Lib: to connect those schematic symbol pins to the pads in your PCB footprint, the pad numbers 
you set here in the Footprint footprint must be the same.

https://docs.easyeda.com/PCB/Route/index.html
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Shape: Round , Rectangular ,  Oval and Polygon.

EasyEDA supports four shapes: Round  ,  Rectangular  , OVAL  and POLYGON .  

OVAL  PAD will give your more space.   
POLYGON  PAD will let you to create some strange pad.  

Like in the image below, you can edit the PADs points when you select a POLYGON  PAD

Layer: If the pads are part of a SMD footprint, you can set it to Top layer or Bottom layer. For 
through hole components you should set it to Multi-Layer. If it setting as mult-layer, it will 
connect with all copper layers.

Net: You don't need to enter anything here because at present this footprint is not connected to 
anything in a circuit.

Width and Height: When the shape is set to Round, Width will equal Height.

Rotation: Here you can set the Pad's rotation as you want.

Hole(D):  This is the drill hole diameter for a through hole pad. For a SMD Pad, set its layer to 
TopLayer or BottomLayer.

Hole Shape: Round and Slot. When it is set as a slot, the Gerber is generated through the 
stitching of multiple drill holes in the corresponding position. If your hole is round, please do not 
set it as a slot, so as to avoid the overlapping error of holes during the production of DFM 
detection.

Center-X and Center-Y: using these two attributes, you can set the pad's position with more 
precision, compared to using the mouse.

Plated： Yes or No. When you set it as No, this pad Inner wall do not metallization.

Paste Mask Expansion: For single layer pad. This property affects the size of the tin area on the 
plate of the steel mesh. If you want to set a pad that is not open in the steel mesh, you can set 
the value to be negative, which is usually larger than the diagonal of the pad.

Solder Mask Expansion： This property affects the size of the green oil area cover on the pad. If 
you want to set a pad not open covered with green oil, you can set the value to be negative, the 
value is usually set larger than the diagonal of the pad.



And you can select a track/Solid Region, right-click it and convert to a pad.

  

Via  

When you want to lay a multilayer PCB, you need to add Vias for nets getting through layer and 
layer. 

  

 

Place a Via on a Track

When placing a via  on a track, the track will be cut to two segments, and the via net will follow 
track's net.  Placing two vias on a tracks, you will get three segments, then you can change one 
segment to other layer id, or remove one of them. 

  

Place Multiple Vias
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Click the copper area outline, click the "Add/Remove Vias" button. this feature needs the same 
net copper areas on two and more layers in the same time, the cross area will add the vias.

Notice: 

EasyEDA only support the through via for all layers, doesn't support the Buried Blind/via. 

Text  

You can add more fonts from your computer or download some free 
fonts:www.1001freefonts.com and free fonts: http://www.fontspace.com/.

  

if you need Japanese or Korean you can use Google Noto fonts
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Select the text, then you can find a Font-family attribute on the right panel like in the image 
below.

Click the add button, then choose the font, the font file must be ttf  or otf .

  

So you can add any fonts by yourself. EasyEDA doesn't cache the font on our server, so if you 
close the editor, you need to add the font again by yourself.

Note: If you use the other font, the LineWidth  attribute is useless, because it will be automatically set 
by changing the Height .

 

Arc  

You can draw many Arcs with different sizes, it's easy to create a pretty cool PCB as you like.  
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EasyEDA provides two Arc tools:

Start point fixed, you can change the end point position and radius.

  

Center point fixed, you can change the radius.

  



Select the arc, you can change the arc type at property panel, different arc type has different drag 
behavior.

  

 

Circle  

You can draw a circle in PCB. If you want to draw a circle at TopLayer or BottomLayer, please use 
Arc.

  

 

Move  

This option is same as schematic's drag.

  

Hole  
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There were lots of users that didn't know how to use PAD or VIA as a HOLE, they asked EasyEDA 
for help, so EasyEDA added a HOLE TOOL in the PCB toolbar. 

And if you want to create the slot hole, you can use solid region(Type: NPTH), or route a track, 
and then right-click the "Convert to NPTH" menu.

Image  

On PCB and Footprint editor, there is a nice feature on the PCB Tools bar.
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After clicking on the image icon, you will see the Insert Image window as below.

In this dialog, you can choose your favorite image, EasyEDA support JPG , BMP , PNG , GIF , and 
SVG . Unlike some other EDA tools which only support a Monochrome Bitmap image, EasyEDA 
supports full color, but Monochrome Bitmap is welcome.

You can adjust the color tolerance, simplify level and reset the image size there.

And you can select shape invert. 

The image will be inserted to the active layer, if it is not right, you can change the attribute. Such 
as TopSilkLayer.  
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Canvas Origin  

This option is the same as schematic's Canvas Origin.

  

Protractor  

We provide a protractor for PCB tools. 

Connect Pad to Pad  

When creating a PCB without a Schematic, none of the pads on the Footprints have nets 
connecting them so there will be no ratlines. 

  

Rather than try to track the pads from scratch, it is a good idea to connect them up by hand first 
using  Connect Pad to Pad  from the PCB Tools palette. This will help you to remember to track 
the pads correctly with fewer mistakes.   
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You could also do this by setting net names for all the pads: if the two pads are given the same 
net name then EasyEDA will understand that they are connected together and will automatically 
create a ratline between them. 

  

Or you can set these two pads with the same net name at the right panel Pad Properties after 
you click the pad.

 

Copper Area  

Sometimes you will want to fill in or flood an area with copper. Usually this copper area will be 
connected to a net such as GND or a supply rail. You can draw the outline of a flood using the 
Copper Area button from the PCB Tools palette.

  

When selecting a copper area, you can find its attributes from the right hand Properties panels.
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The more information please refer at PCB: Copper Pour

Solid Region  

EasyEDA has added a new tool Solid Region for PCB design

This is a very useful, quick way to connect Pads. You can draw a Solid Region to include all of 
these pads with same net name, then set the region to the same net name as the pads. It is like 
Copper Area but easier to use for small areas. To use Solid Region like this, set the Type attribute 
(in the right hand Properties panel)  to Solid.

The more information please refer at PCB: Solid Region

Measure/Dimension  

https://docs.easyeda.com/PCB/Copper-Pour/index.html
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Making and adding measurements is useful in PCB design. EasyEDA provides two methods to do 
this.

1. Dimension tool in the PCB Tools palette:
  This tool can show three units on the canvas, milliliter, inch and millimeter.

When you click one side of the dimension on the PCB, you can drag it for any directions or 
change its length.

2. Measure a distance using Hotkey M, Or Via: Top Menu > Edit > Measure Distance, then 
click the two points which you would like to measure.  

Tips: 

It's unit follows canvas's units.   
You can disable the snap option to measure at the canvas property panel.

Rect  

It looks like a Solid Region, but it can't be set Nets and you can't set the Layer as NTPH.
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The rect doesn't rotate, you can change its width and height.

Group/Ungroup  

Just like Group/Ungroup in the Schematic Editor can be used to create a schematic lib symbol, 
you can use Group/Ungroup from the PCB Tools palette to create a Footprint footprint in the PCB 
editor.

  

For example, place Tracks and Pads on the canvas, then select all of them and click 
Group/Ungroup to group them like as a footprint in the image below:

Notice：

Before ungroup the footprint, please change it's layer to top layer first, because of the 
footprint after grouping will at top layer.
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The grouped footprint doesn't support Import Changes, it will be removed if you Import 
Changes.

 

Layers Tool and Objects  

Layers Tool  

Active Layer: The colours of the layers in the Layers Tool are defined in the Layer Options 
Settings. To work on a layer then you must make it the Active layer.    

To do this, 

Click on the eye icons to show/hide layers.  
The pencil icon in the coloured rectangle indicates that this is the active layer.   
Click the pin icon to fix the layering tool without automatically closing it.
The height and width of the layer tool can be adjusted when dragging the lower right corner 
of the Layers Tool.

HotKeys for layer activation:  

T: Top Layer is active  
B: Bottom Layer  
1: Inner1 Layer  
2: Inner2 Layer  
3: Inner3 Layer  
4: Inner4 Layer  

The more information for the PCB layers please refer at PCB Layout - Layer Manager

note: the hidden PCB layer is only visually hidden. The corresponding layer will still be exported 
during photo preview, 3D preview and Gerber export.

Objects Filter Tool  
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Click "Object" to switch to object filtering.

Select： When the tick in front of the object is checked, the corresponding object in the canvas 
can be manipulated with the mouse. Uncheck will not allow mouse operation. Including click 
selection, box selection, drag and other operations.

Eye： Click eyes to modify the display and hiding of corresponding objects in batches. 

Component：Displays or hides the entire components, excluding the component's name 
and prefix
Prefix：Displays or hides the entire components' prefix
Name：Displays or hides the entire components' name
Track：Displays or hides the entire tracks, for all layers
Pad：Displays or hides the entire free pads, excluding the pads in the component
Copper Area：Displays or hides the entire copper areas' fill area, excluding copper outline
Text：Displays or hides the entire normal texts, excluding the text of the component

Note: 

The layer and object invisible and visible will not go into Undo and Redo.

 

 

Layer Manager  

Layer Manager  

You can set the PCB layer's parameters at the Layer Manager.

Via Top Menu> Tools > Layer Manager..., Or Click Layers Tool gear icon. Or right-click the 
canvas - Layer Manager menu.

The Layer Manager dialog:
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The Layer Manager setting only works for the current editing PCB.

Copper Layer: The copper layer of your PCB. EasyEDA support 34 copper layers. The more 
copper layers the PCB will be more expensive. The TopLayer and BottomLayer is default layer, 
can not be disable. If you want change the copper layers from 4 to 2, you must delete the inner 
layers objects first.   

Display: If you don't want a layer dosen't display at "Layers Tool", you can disable the checkbox.  
Notice: This option only hide the layer name on the "Layers Tool", the objects of the hidden layer 
still exist, when you generating the Gerber, they will appear.

Name: Layers name. For the inner layer, you can define the name.  

Type: 

Signal: Which is working for the signal. Such as Top and bottom layer.
Plane: When the inner layer type is "Plane", this layer will be copper pourred, if you want to 
separate the copper area you can draw the Track or Arc. You can treat this layer is a only 
has the copper area, but its easy than draw the copper area. The track you routed will 
generate the clearance when generating the Gerber. The "Plane" usually is using for the 
Power or Ground copper pour on the inner layer. You can set the net for the plane zone. 



   

Notice: 
When draw the track to separate the plane zone, the track start ponit and end point must 
over the middle line of the board oultine track. Otherwise, the plane zone will not be 
separated; When using the plane layer, the PCB can not exist two closed borad outline, only 
one closed board outline will generate the plane zone.
Non-Signal：Such as silk screen, mechanical layer, document layer etc.

Color: You can define the color for each layer.

Transparency: You can change the layer transparency.

Layer Definination:

TopLayer/BottomLayer: The top side and bottom side of the PCB board, copper layer.
InnerLayer: Copper layer, routing track and copper pour.
TopSilkLayer/BottomSilkLayer: Board silkscreen.
TopPasteMaskLayer/BottomPasteMaskLayer: This layer is the layer used to make the 
stencil for the SMT pads, helping to solder. This layer has no effect on production if the 
board is not required to make the stencil.
TopSolderMaskLayer/BottomSolderMaskLayer: The top and bottom cover layers of the 
board are typically green oil, which acts to prevent unwanted welding. This layer belongs to 
the negative film drawing mode. When you have wires or areas that do not need to cover 
green oil, draw them at the corresponding positions. After the PCB is generated, these areas 
will not be covered with green oil, which is convenient for operations such as tinning.
BoardOutline: The board shape definition layer. To define the actual size of the board, the 
board factory will produce the board according to this shape.
TopAssemblyLayer/BottomAssemblyLayer: Simplified outline of components for product 
assembly and repair. Used to export document printing, without affecting PCB production.
MechanicalLayer: Record the information on the mechanical layer in the PCB design, and 
only use it for information recording. By default, the shape of the layer is not manufactured 
at the time of production. Some board manufacturers use the mechanical layer to make the 
frame when using Altium file to production. When using Gerber file, it is only used for text 
identification in JLCPCB. For example: process parameters; V cut path etc. In EasyEDA, this 
layer does not affect the shape of the border of the board.
DocumentLayer: Similar to the mechanical layer. But this layer is only visible in the editor 
and will not be generated in the Gerber file.
RatlineLayer: PCB network ratline display, this layer is not in the physical sense, in order to 
facilitate the use and set color, it is placed in the layer manager for configuration.
HoleLayer: Similar to the RatlineLayer. For Hole(Non-Plated Hole) display.
Multi-Layer: Similar to the RatlineLayer. For multi-layer hole(Plated hole) display. If the PAD 
setting layer property as mult-layer, it will connect with all copper layers.



DRCErrorLayer Similar to the RatlineLayer. For DRC(Design Rule Error) marking dispaly.

Layout Single Layer PCB  

The PCB copper layers of EasyEDA are double, EasyEDA doesn't support layout a signle layer 
directly. if you want to layout a single layer PCB(such as only layout on the bottom layer), 

There are two methods:

Method 1:

Route the track and copper on the bottom layer, and without placing via.
If you are using the footprints which have the multi-layer pads, that will appear on the top 
and bottom layer, then you need to change all multi-layer pads "Plated" as "No".
Generate the Gerber, decompress the Gerber zip file, delete the layers which you don't 
need(such as Gerber_TopLayer.GTL, Gerber_TopSilkLayer.GTO, 
Gerber_TopSolderMaskLayer.GTS, Gerber_TopPasteMaskLayer.GTP).
And re-compress the Gerber to a zip file, and order it.

Method 2:

Design your PCB at one side, if other side has pads etc, you don't need to deal with them.
Generate the Gerber.
Add the comment for mention that you need to order the signle layer PCB when order the 
PCB.

 

Ratline  
 

When you layout the track in the PCB, Between Pad and Pad as they have the same net name, a 
Ratline will be automatically shown among them to reveal that they can be connected with a 
track.

1. If you want one ratline do not show on the PCB editor, you can deselect the net in the 
design manager, as below deselect +5V :
If you still draw a track in +5V  after deselecting, canvas will not display this track and ratline 
, but it will show a net text with +5V  as below.
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Based on this skill， you don't need to lay GND net before copper area in the PCB.
2. If you want to check the ratlines with highlight, you can click the pencil on the Ratlines Layer 

as below, and you can change the ratline's color at Layer Manager.

3. If you want to hightlight one ratline all the time, you can click a pad, press hotkey H, press it 
again unhighlight.

4. If you want to change one ratline's color, you can set it at:  - Tools - Net Color. After setting 
the color, you need to click the plus icon on the right. The color is not affected by the color 
of the ratline layer.

5. If you want to remove one ratline, you just need to remove objects' net. Select it and empty 
the net.
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PCB Net  

Net Name Visible  

PCB editor can display net name in the track or Pads, if you don't need this feature, just need to 
turn it off via： 

Top Menu > View > PCB Net Visible, or press hotkey CTR+Q  .

  

Net Length  

After selecting a track, and then pressing H  key or click its net at Design Manager, EasyEDA will 
highlight the whole net and pop a message box to tell you the whole net's length. like in the 
image below
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Net Color  

If you want to change one Ratline's or Net's color, you can set it at:  Top Menu- Tools - Net Color. 
After setting the color, you need to click the plus icon on the right. The color is not affected by the 
color of the ratline layer.

When you set a color for a net, you need to click the + button to make it works.

 

Board Outline  
 

Before placing footprints we need to create a board outline. The board outline must be drawn 
on the Board OutLine layer. So first, set Board OutLine as the active layer, then draw the board 
outline using Track and Arc from the PCB Tools palette.
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When converting a Schematic to PCB, EasyEDA will try to create a board outline for you.

The area of the default board outline area is 1.5 times the sum of the area of all of your 
footprints, so you can place all of your footprints into this board outline with some allowance for 
tracking. If you do not like the board outline, you can remove the elements it is made up from 
 and draw your own.

To create a simple rectangular board outline, this arc can be removed and the line X and Y end 
points edited - either directly in the Properties panel or by dragging the line ends - to close the 
rectangle.

And EasyEDA provides a Board outline wizard, so it is very easy to create a board outline.
Via: Top Menu > Tools > Set Board Outline, Or find it on the toolbar.  



In this dialog, there's a choice of 3 types of board outlines, Rectangular , Circular, Round Rect. If 
you need a different more complex board outline, you need to import a DXF file.

Notice：

When generate the Gerber, EasyEDA will show error if the board outline doesn't closed or 
the board outline tracks overlap.  
You can cutout the hole by using the board outline, or use Hole , or Solid Region(Type: 
Board Cutout)  to create the hole instead of using the board outline.
You can right-click track or circle to convert to board coutout.
If the board outline doesn't closed, the copper pour will not show up.

 

 

Route Tracks  
 

Route Tracks  

In the schematic editor, we use Wire or the W  Hotkey to connect Pins, in a similar way in the PCB 
editor, we use Track to connect Pads. Track allows you to draw PCB tracks and can be found on 
the PCB Tools palette or using the W  Hotkey (not T).

Some Tips about Track
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1. Single click to start drawing a track. Single click again to pin the track to the canvas and 
continue on from that point. Right click to end a track. Double right-click to exit track mode.

2. Drawing a track at the same time as using a hotkey(for example hotkey B ) for changing the 
active layer will automatically insert a Via:  

  

If you start drawing a track on the top layer, you will see it drawn in red, then press the B key to 
change to bottom layer and you will see EasyEDA insert a grey via and then the track will 
continue being drawn but now on the bottom layer in blue.

3. Pressing the +  or  -  Hotkeys when drawing the track will change the width of the track on the 
fly. Use the hotkey TAB  to change the track width.

 



4.  Double clicking on a drawn section of the track will add a new vertex at that point. You can 
drag the vertex to form a new corner. And you can right-click the point and delete it. 

  

5.  Click to select the track and then Click and Drag on a segment of the track to adjust the 
segment between vertices. 

6.  Pressing the L  Hotkey when drawing the track will change the track's Route Angle on the fly. 
And you can change Route Angle on the Canvas Attributes of the right panel before the next 
drawing.  

  



7.  You can change inflection direction when routing, just press Space  key.  

8. If you want to route a track and use "L", and the then press "+", you will get two different size 
track segment. or press "SHIFT+W".

  

9. If you want to create the solder mask aperture for the track, you can use "Expose Copper" 
when you select the track on the right-hand panel. The solder mask will bigger 4mil than the 
track.

 



10. And if you want to create the slot hole, you can route a track, and then right-click the "Convert 
to Board Cutout" menu.

  

11. You can make track routing width follow design rule, after enable the design rule option.

12. Right-click the track, you can select the track connection or a whole same net tracks.

  

13. If you want to the whole track, you can press SHIFT  and move it.



14. You can disable the DRC boundary at Desgin Rule. The size follow the rule.

  

15. If you want to continue routing for a net, you can disable the "Terminate Routing 
Automatically" option at "Setting - System Setting - PCB".

  



16. Set up Remove Loop while routing, it only works on copper layer. 

  

17. Using Routing Conflict as "RoundTrack" will help you finish routing quickly.

  

18. When edit the footprint document, you can set up the "Cut Silkscreen" to avoid the silkscreen 
track overlap the pad.

  

Track Length



When a track is selected, you can find its Length attribute in the right panel.  

  

At left-hand Design Manager, click a net, will pop up a dialog to show you this net track 
length.
Click a track, press hotkey H will keep hightlight this track and net, and show this net's 
length.

Delete a Segment from a Track

While routing, if you want to undo previous track path, you can press key "Delete" or 
"Backspace".
Move your mouse to the segment which you want to delete, click it, then hold SHIFT  and 
double click it. the segment will be removed. Or right-click delete the node.  
Right-click the track node to delete the track
Click the track, right-click delete it, or press "Delete" key directly.

DRC outline

When you routing a track on the signal layer, you will see an outline around the first track, it is 
the DRC outline, the clearance from outline to the track edge depends on your Design Rule(DRC) 
clearance setting.



Routing Conflict  

When the PCB comes from the schematic converted, the "Routing Conflict - Block" will be opened 
automatically.

At the right-hand attributes panel - others, you can find a "Routing Conflict" option:

  

Ignore: You can route the track overlap the different net name objects.
Block: If the track net name different with other objects, this track will be blocked when 
routing.
RoundTrack: The track while routing will walk arroud the different net objects.
Push： Doesn't develop yet.

Differential Pair Routing  

EasyEDA provide a easy experience for the differential pair routing.
Via: Top Menu - Route - Differential Pair Routing

You must make sure the Differential Pair net names must be XXX_N, XXX_P  or XXX+,XXX- .

and you need to set Differential Pair net rule at the "Top Menu - Tool - Design Rule" first.

How to route Differential Pair:

1.Set the Differential Pair net name as XXX_N, XXX_P  or XXX+,XXX- , and set the rule for the 
Differential Pair net at the "Design Rule"
2.Click the menu Top Menu - Route - Differential Pair Routing

3.Click the one pad of the Differential Pair pads
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4.Routing

Notice:

Only for 45 degrees routing, doesn't support hotkey L and Space key.
Doesn't support the fanout routing.
Doesn't support the DRC blocking.

Known Issue:

When finish previous routing location too close with the finish pads, the track will generate 
the extra segments, please finish the previous location far away from finish pads.

  

Track length Tunning  

You can tunning your track very easy on the editor.

Via: Top Menu - Route - Track length Tuning
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How to use:

1.Select the track which is you want to tune
2.Click the menu: Top Menu - Route - Track length Tunning

3.Set the parameter, start
4.Left-Click the track where is you want to start, and then move the mouse
5.When the track length close your setting, it will stop tunning.

Notice：

Doesn't support one side tunning for a track yet
Doesn't support auto push or avoid the nearby tracks yet

Cloud Auto Router  
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For some simple or prototype PCBs, you may want to use the auto router function to save time. 
Layout is a time costly and dull job. EasyEDA spends lots of time to provide such a feature and it 
is loved by our users.
Before using the auto router, you need to set the board outline for the PCB.

Auto router is not good enough! Suggest routing manually! You can use "RoundTrack(Walk 
Arroud)" option to route tracks, via right-hand panel - Routing Conflict.

Steps:

1 Click the the auto router button from the Top Menu"Top Menu> Route > Auto Router"

2 Config the auto router

 After you click that button, you will get a config dialog like in the image below.  

 

In the config dialog, you can set some rules to make the auto router result professional. These 
rule must equalize or more than DRC setting.

General Options  

Unit: The unit follows PCB canvas unit.

Track width: The auto-route track width.

Clearance: The clearance of the objects.

Via Diameter/Via Drill Diameter: The via placing by auto-router. 

Realtime Display: when you select it , the real time routing status will show on.

Router Server: 

Cloud: Using EasyEDA online server.
Local: Using the local auto router server, when you click the Auto Router icon, the 
editor will check the local router server available or not automatically. How to use 
please see as below.



Router Layers: If you want to route inner layer, you have to enable the inner layer first.

Special Nets: For the power supply track, you may want it to be bigger, so you can add 
some special rules. 

Skip Nets:  If you like to keep the a net with no route, you can skip it. For example, if you 
want to use copper area to connect GND  net, you can skip the GND  net. If you want to 
reserve the routed track, you need to select the Skip Routed Nets .

3 Run it

After click the "Run" button , The real time check box will let you see how it is going, but it will 
make the process a little bit slow. 

  

Waiting for a few minutes, after adding bottom and top copper area, you will get a finished PCB 
board.

When finish, will pop up a window.

  

The connection means the track connect times.

Notice：

The parameter can't less than DRC rule, otherwise will report error.
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Local Auto Router  

EasyEDA suggest that using local auto router rather than using the cloud server,  because when 
many users using cloud server, the cloud auto router will fail. Only support 64bit system.

 

For the local auto router, please follow the steps as below:

1.Download the local auto router server. 
EasyEDA：EasyEDA Router.zip(134MB)
Supported OS:

Windows7(x64) or later 64bit Windows
Ubuntu17.04(x64) or other 64bit Linux, Linux recommend Deepin
macOS(x64)   

2.Unzip it to the User folder, such as driver D.

3.Configure the browser. 
Notice: Please use the latest Chrome or Firefox !!!   

1)Chrome 
The Chrome Browser don't need to be configure, If the local auto router is unavailable, 
you have to upgrade Chrome to version 60.0.3112.78 or later.

2)Firefox

1.Type "about:config" into the address bar then press enter.
2.Search and double click the options as below (change the values to "true"):  

network.websocket.allowInsecureFromHTTPS    

security.mixed_content.block_active_content  

   

  - 3.Re-open Firefox.   

4.Open the decompress folder, Start local Auto Router(don't need to install, just run it 
and keep the command window open):    

Double click win64.bat  in Windows.
Run sh lin64.sh  on command terminal in Linux. Open the terminal, use the cd  
command to change the directory to the lin64.sh  location, and type sh lin64.sh , 
then enter.
Run sh mac64.sh  on command prompt in MacOS. Open the terminal, use the cd  
command to change the directory to the mac64.sh  location, and type sh mac64.sh , 
then enter.
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5.Open the editor, open the PCB, Click the Auto Router** icon at editor to start auto-
router.** 
If the local router server is available, the dialog will tell you. Click the Run button, the dialog 
will show the process.

Tips

Sometimes, if you can't get it done, try the tips below.

Make sure the net of PCB doesn't contain the special charaters, such as  ; ~ \ / [ ] =  etc. the 
chrarter - and _ are supported.
Make sure the board oultine is closed, doesn't has board oultine overlap situation.
Make sure there are no DRC cleance errors (short circuit issue), such as two different 
network pads overlapping, or different net pads in the same location within the footprint.
Make sure no footprint outside the board outline.
Make sure PCB rule doesn't have 3 decimal places, EasyEDA auto router only support 2 
decimal places.
Skip the GND nets, add copper area to GND net.
Use small tracks and small clearance, but make sure the value is more than 6mil.
Route some key tracks manually before auto routing and ignore them when auto routing. 
Add more layers, 4 layers or 6 layers， but that will make the PCB more expensive.
Change the components layout, make them have more space between each other.
Don't make any via/pad/solid region overlap the different net objects.
Use local auto router rather than cloud server.
Tell the error detail to us and download and send your PCB file as EasyEDA Source json file:
https://docs.easyeda.com/en/Export/Export-EasyEDA-Source-File/index.html
via email.

  

Some professional people don't like the auto router, because they think auto router is not 
professional, but you can use the auto router to check your placement to check the density of 
your PCB. 

At present, the auto router is not good enough, suggest routing manually, we will improve it in 
the future.

 

Copper Area  

Copper Area  

Sometimes you will want to fill in or flood an area with copper(Copper Pour). Normally after 
drawing the copper area, set the net it is to be connected to (floating copper areas are not 
recommended because they can cause EMC and Signal Integrity (SI) problems).

https://docs.easyeda.com/en/Export/Export-EasyEDA-Source-File/index.html
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Before using Copper Area, please make sure your PCB has a closed board outline!

Usually this copper area will be connected to a net such as GND or a supply rail. You can draw 
the outline of a flood using the Copper Area button from the PCB Tools palette.

Copper Area Attributes  

When selecting the copper area outline, you can find its attributes from the right hand 
Properties panels.

Layer: Bottom, Top, Inner1, Inner2, Inner3, Inner4 etc.;

Net: the net that the copper area is connected to;

Name: set a name for it.

Clearance: clearance of the copper area from other nets and floods;

Pad Connection: direct or spoke (i.e. a cross shaped heat shunt);
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Spoke Width: When Pad Connection is Spoke, you can set the Spoke width, which is copper area 
fill connect with Pads.

Keep Island: Yes/No. This keeps or removes any isolated areas of copper created as part of the 
flooding process. It is usually good practice to removes these unless you really need them to 
maintain a more even spread of copper (copper balance) on your PCB.

Fill Style: Solid/No Solid/Grid. Selecting No Solid will removes the fill so that you can see the 
tracks more clearly; when select Grid, you can set the grid spacing and grid width.

Copper to BoardOutline: Setting the clearance between copper with board outline.

Improve Fabrcation: Yes/No. If you set as No, you will see much sharp copper corners, that is 
not good for PCB fabrication.

Rebuild CopperArea: Click the button to Rebuild Copper Area if you make any changes.

Edit Points: You can edit the copper area shape manually, any shap as you want.

Add/Remove Vias: When you add copper areas at two and more layers which are having same 
net, you can add multiple vias for the copper fill area, just click the "Add/Remove Via" button, 
then set the via parameter. The vias will avoid the objects if the via conflict the DRC.

Tips  

Hotkey E  to start draw copper area.
Hotkey L  to change drawing type(90 degrees or 45 degrees or Arc)
Hotkey Shift+B  to build all of the copper areas.
Hotkey  Shift+M  to hide copper areas fill zone, just show the copper outline.
Hotkey Delete  or BackSpace  to redo previous steps.
If you after copper pours but no copper fills show up, you need to set it a net same one of 
the PCB nets, or keep the island as YES, and the rebuild the copper area via "Rebuild Copper 
Area" button or "SHIFT+B".
If you want to hide the copper area and keep routing tracks, you can set the copper zone 
invisible at the right-hand panel.
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If you want to cutout some copper corners, you can use "Solid Region - No Solid", and then 
set different net for it, and rebuild the copper area.

  

Notice  

Because of the browser's performance issue, EasyEDA doesn't support the real-time copper pour, 
after PCB modifying, please rebuild copper area via Hotkey Shift+B  .
EasyEDA doesn't support click the copper zone, you need to click the copper outline to select it.
The copper filled data is stored in the client or browser(that is because some copper 
filled data is too large to save at server), and the copper area outline data is stored in 
the file. Therefore, when the PCB is opened for the first time, the copper area filled 
data will be automatically pouring and saving at local, and the second time the PCB is 
opened, the filled data will be automatically loaded from the local storage. When you 
need to draw the forbidden copper-laying area, please use the "No Solid" property of 
"Fill Type" to cutout the copper area and rebuild it, do not use the operation of 
drawing the area with wires or circles and then removing the wires or circles to create 
the forbidden copper pour area.

FAQ  

Why sometimes it takes a long time to copper pour

1. Check that the PCB has a large number of polygon pads, which generally appear in the PCB 
imported Altium Design files, and if so, manually modify them to Round or Rectangle pads.
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2. Check if there are a large number of wire arcs, generally appear in the imported Altium 
Design PCB, Altium Design picture is a large number of track segments combined, need to 
be manually removed.

3. Check that the board outline is complicated, with overlapping board outlines, or a large 
number of board outlines, adjust them manually to reduce the number of board outlines. 

Why did I not show the copper fill after copper poured

1. Your copper area net must have the same pad or via semen as the current layer, otherwise 
it will be considered an island to be removed. Click on the copper wire frame to modify the 
net in the property panel on the right. For example, your pad net is VCC , you lay copper net 
needs to be set to VCC .

  

2. If you don't change the copper area ne, you can click on the copper outline and modify the 
property "Keep Island" to Yes in the right property panel.
The copper area logic of the EasyEAD is based on whether there is a connection or not to 
decide whether it is an island, and if there is no element connection to the same net, the 



copper area will be considered an island.

  

3. Check that the editor version is 6.3 above, 6.3 PCB board open in version 6.2 can not 
properly copper pour. Please CTRL+F5 refresh editor page upgrade to 6.3, if it is true that 
can not upgrade to 6.3, you must remove the copper area and redraw.

  

4. Check that the board outline is closed and that endpoints need to be closed between the 
tracks, and that there are overlapping segments of the board outline (usually inside the 
imported PCB). Once you can hide all layers, only the board outline layer view is displayed, 
and each segment is carefully examined.

 

5. Check that the copper area property is set to type No Solid and needs to be set to Solid or 
Grid.



  

6. Whether to make the copper area invisible, on the right side of the canvas, set the copper 
zone to Visible.

  

7. Still unable to copper pour may be an editor bug, please contact us.

Copper Area Manager  

EasyEDA support copper area manager now, you can set the copper order and apply, the 
forward copper area will be poured first. 

Via: Top Menu - Tools - Copper Area Manager

For example：
The GND on the top and VCC on the top, you can see the clearance is different.
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Solid Region  
EasyEDA has added a new tool Solid Region for PCB design

This is a very useful, quick way to connect Pads. You can draw a Solid Region to include all of 
these pads with same net name, then set the region to the same net name as the pads. It is like 
Copper Area but easier to use for small areas. To use Solid Region like this, set the Type attribute 
(in the right hand Properties panel) to Solid.

When you drawing the solid region, you can use the hotkey L  and space  to change the route 
type(Arc, 90 degrees, 45 degrees, Free Angle), just like the track routing.
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When you finish drawing, you can click the solid region and change its attributes at the right-
hand panel.

Layer: Solid Region su pport many layers, you need to enable the layer at the Layer 
Manager first.

Net: When change to top or bottom or other inner signal layer, the solid region can be set a 
net to connect other objects. Sometimes, you can use solid region to make the copper 
instead of "Copper Area".

Type: Solid,Board Cutout,No Solid ,

Solid: It will fill the solid area.
No Solid: It will cutout the area such as copper area. Notice, if you cutout a copper 
area, the solid region's net must different than copper area's net. After setting to 
this option, you need to rebuild the copper area with SHIFT+B.
Board Cutout: you can use this feature to create a slot hole(Non Plated Through Hole).

Edit Points: You can edit the solid region's outline points as you want.

Expose Copper: ou can create an aperture in the solder mask by one click. It's very easy to 
do.

The outline of the solid region can not be self-intersection, when it happens, please delete the 
self-interation point at "Edit Points".

 

Distribute Array  
 

EasyEDA doesn't support the paste array, but EasyEDA provide a powerful function - Distribute 
Array. It works at PCB, Footprint, PCB module.

Via: Top Menu - Align - Distribute Array

How to use: Selected the objects - Click the Distribute Array - Set the parameters, and apply.

Retangular:
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Item Rotation: The rotation of the item, if you set 30 degrees, all selected item will rotate 30 
degrees.

Location: The location for the first item to place. on the left-top corner of the items.

Distribute By:

Column: From top to bottom, and then from left to right, like word N.
Row: From left to right, and then from top to bottom, like work Z.

Circular:

Item Rotation: The rotation of the item.
Location: The center location of the circle.
Radius: The radius of the circle.
Start Degree: The start degree of the first item. 0 degree is on the middle of the right side.
Direction: The forward direction of the items. Anti-Clockwise or Clockwise
Spacing(Degrees): The spacing between each item.
Rotate Item to Match: If choose Yes, the item will rotate to match the circle. When setting 
Yes, the item actually rotation will be "Item Rotation + Spacing".

Before Rotate Item to Match:



After Rotate Item to Match:

 

Teadrop  
Via: Top Menu - Tools - Teardrop

You need to set the parameter first, and then Apply.
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When delete the track, the teardrop will be deleted too.

If the teardrop detect the DRC errors while generating, this teardrop will not generate.

At present, doesn't support add teardrops for one part.

In fact, the teardrop is a Solid Region, when you select it, you can modify its attributes.

 

Design Rule Check(DRC)  
 

EasyEDA provides a real time DRC(Design Rule Check) function. This is a big feature of EasyEDA. It 
is hard to fix DRC errors after laying out the PCB. Now EasyEDA will let you know the error in 
routing. You will find an X  flag to mark the error.

Design Rule Setting  

Via at: Tools > Design Rule..., or Via: right-click the canvas - Design Rule... to open the Design 
Rule setting dialog:  
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The unit follow the canvas unit.

Rule: The default rule named "Default", you can add the new rule you can rename and set 
parameters for it. Each net can be set a rule.  

Track Width: Current rule's track width. The PCB track width can not less than this value.

Clearance: The clearance of different objects which have different net. The clearance of the PCB 
can not less than this value.

Via Diameter: The via diameter of current rule. The via diameter of the PCB can not less than 
this value. Such as the Hole/Multi-layer Pad's diameter.

Via Drill Diameter: The via drill diameter of current rule. The via drill diameter of the PCB can 
not less than this value.

Track Length: All track length of current rule. The length of tracks belong to a same net should 
not be longer than this value.Including the arc lenghth. When the input box is empty the length 
will be unlimited.

Realtime DRC: After enable, when you routing the DRC will checking all the time, when appear 
the error the canvas will show the "X" marking.



Check Object to Copper Area: Check the clearance of the objects to copper area. If you disable 
this option, you must rebuild the copper area before generating the Gerber with SHIFT+B.

Check Object to Board Outline: When you enable, you can set a value to check the clearance of 
the objects to board outline.

Apply Design Rule while Routing and Placing Via: When you routing and placing a new via, 
them will follow the design rule to set them width and size.

Show DRC Boundary while Routing: When routing you will see a oultine around the track. Its 
diameter depends on desgin rule.

Set Rule for a Net  

1. Click the "new" button to create a rule, or use the default rule
2. Select one or more networks on the right, support holding down the CTRL key for multiple 

selection, and also can perform keyword filtering and rule classification filtering
3. Then select the rule you want to set in the "set rules" section below and click the "apply" 

button. The network applies the rule.
4. Click the "Settings" button to apply the rule.

Check the DRC Error  

Via "Design Manager - DRC Error" or "Top Menu - Design - Check DRC", click the refresh icon to 
run the DRC. If your PCB is a big file, and have the copper area that will take some times to check 
the DRC, please wait a while.

  

af://n3334
af://n3344


After checking, you can view all the error at the "DRC Error", click the error the related objects will 
be highlighted.

 

Note: 

When you convert a schematic to PCB, the real time DRC is enable. But in the old PCB, the real 
time DRC is disable. you can enable it in the image as above. 
Design rule checking can only help you find some obvious errors.
The color of the DRC error can be set in the layer manager.

 

Footprint Attributes  
 

When selecting a Footprint, you can find its attributes at the right hand Properties panel.
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Prefix: It is same as the schematic. If you move the prefix too far away from the footprint, it will 
be dragged back to the footprint when you open the PCB again, if you don't need the prefix 
please set the prefix display as No.

Layer: You can set a footrpint to be on the TopLayer or BottomLayer, it same as board side. 
*Note: The footprint mirrors when it swapping layers. it doesn't support to mirror at current 
layer.**

X-Location and Y-Location: Moves the origin of the footprint to a precise position.

Rotation: Rotates the footprint about its origin over the range from 0o to any angle in 
1o steps (visually of course multiples of 360o will appear identical).

ID: EasyEDA will assign a unique ID for each footprint automatically, you can't modify it.  

 

Change Attributes in Batch on PCB Editor

Sometimes, we need to change some attributes of multiple objects together, such as the track 
width, hole size and font size.
Now, you can select them and do some changes. 

Taking the track for an example. If you select 3 tracks, now you can change their Width , Layer , 
Net  together.  The difference property values will combine as <...> , change it directly will apply 
to all seleted objects.



 

 

Design Manager  
 

Just like Schematic's Design Manager, PCB's Design Manager can be found via:

Left Navigation panel > Design

or just press the  CTRL+D  hotkey to open the Design Manager dialog.

In this dialog, you can:

Click the icon to jump to folder.
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Click a component/Net/DRC Error to highlight it.

  

Filter to find a component or net.

  

Click a net to highlight the tracks/vias with the same net.

Click a incomplete net will highlight the ratline and objects.

  



Check/uncheck the net to show/hide the ratline of the net.

Double click the net to remove all of the tracks and vias with the net name. If you want to 
reroute a net, this is the recommended method to use to un-route it first.

Click the reresh icon the refresh the list.

  

Notice:

Design Manager list doesn't support to refresh automatically, you must click the refresh icon 
manually.

Import Changes  
 

Import Changes  

Sometimes, while working on a project, you need to make changes to the schematic and then 
update your board, to incorporate them.

It's easy to do this with EasyEDA.

Go to the PCB Editor, via: Top Meun > Design > Import Changes

  

If there are some errors at schematic, such as prefix duplicated, no footprint, it will pop up notice 
dialog, the more information please refer： Schematic - Convert to PCB  
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If no errors, you will get a "Confirm Importing changes information" dialog:

If you are happy with your changes, just click the Apply Change button.

If you want to update the PCB tracks net same as the schemtiac, you need to enable "Also update 
track's net" option.  The editor will update the related track's net depends on the pad's net.

The changes will then be passed into the PCB layout and you can then adjust the tracking to suit.

Notice：

Because of the net of the schematic is generated after calculating, when you change some 
netlabel, after Import Changes, the PCB track will not be deleted.
When enable the "Also update track's net" option, after Import Changes, the related tracks 
vias will update the net from the pads, there will be some nets changed isn't you want, you 
need to change them manually, such change prefix, modify the parts connection, delete or 
add part at the schematic, you can change the tracks net via: right-click the track - click 
Select menu - Connection, and them all connection will be seleted, you can change them net 
at the right-hand property panel.
After Import Changes, there are some action can not be undo.

 

 

Panelize  
via: Top Menu - Tools - Panelize

Panelize by Editor  
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At present, EasyEDA only support to panelize PCB itself, in order to decrease the file size, the 
panelized file only panelize the board outline. 
Normally, all the PCB factory will support this panelized file, if you not sure, you need to contact 
your PCB factory support.

via: Top Menu - Tools - Panelize

The Border height can not less then 3mm.

V-cut:
If you choose V-Cut, the editor will add the v-cut indication track on mechanical layer.



Stamp Hole:

When you preview the Panelize Gerber at JLCPCB.com, you will get the image like below:



JLCPCB will take care of your design, they know how to do.

 

Panelize by Manually  

Process:

1. Select the whole board, hotkey CTRL+A .
2. Copy the whole board by reference point, hotkey CTRL+SHIFT+C  or CTRL+C .
3. Paste the board via hotkey CTRL+SHIFT+V , this hotkey will keep the prefix and hide the 

ratline layer.
4. Paste repeatly, after finish, rebuild the copper area with SHIFT+B , recommend draw copper 

area at the end.

Notice

If the board contains plane layer, it can not be panelized by manually, it will not generate the 
plane zone as you want.
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For some small PCB projects, maybe you don't need a schematic. EasyEDA allows you to lay the 
PCB directly from the PCB Editor.

1. Start a new PCB
2. add footprints directly from the Footprints from Left Navigation Panel Library - Footprint 
3. and then just route track for them.  

The PCB created by New PCB menu directly, it will hide the ratline layer defaultly.

For setting pad to pad connections, you can check the above Connect Pad to Pad section.

  

 

 

PCB Preview  

2D View  

EasyEDA provide a nice Photo View to help you to check the PCB. 

Via: Top Menu - View - 2D View.

  

After converting the PCB to Photo View, you can see the result as in the image below.

          #  Layout a PCB Without Schematic1
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3D View  

After click 3D view menu, the server will generate the 3D view file, when the editor loading finish, 
you will see a pretty cool 3D view.

Change 3D view attributes at the right-hand panel;
Reset the 3D PCB position at the left-bottom corner icon;
Keep left-click and drag the canvas can change the view direction;
Keep right-click and pan can change the 3D PCB position.

3D model view of the component please check "PCB - 3D Model Manager" and "Footprint - 
Import 3D Model" chapter.

 

PCB Information  
PCB design information can be easily obtained by checking PCB information.

Entry:  Top Menu - Fabrication - PCB Information
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Nets shows: routed nets/total nets.

 

 

                     

PCB Module  
 

EasyEDA support create the PCB modules, it seems schematic module.

How to Create  

Via: Save as Module and File > New > Schematic/PCB Module。
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PCB module save at Library > Schematic/PCB module > Work Space > My Libraries

 

How to use  

Since v6.4.3, after placing schematic modules and PCB modules, after Import Changes, supports 
to keep the layout location.

How to use:

1. Draw schematic modules and PCB modules, and ensure that their component prefix are 
one to one, and the footprint is also corresponding. The module's component prefix can not 
have question marks and duplicate prefix, such as U? or two R1.

2. Open schematic and PCB at a same project.
3. Open "Library", select the module.
4. Click the "Place" button to place the previous saved schematic module and PCB module.
5. It will pop up a window to enter English letter.  The letter of schematic module should keep 

corresponding with  PCB modules.
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For example: A component at schematic module is U2, enter letter K, press OK to place into 
canvas, it will be KU2, then PCB module has KU2 too.
Click "OK" and enter the placement mode. After each placement, the pop-up will continue to 
enter the identification letter. Make sure that the identification letters entered each time are 
unique.

6. When finish the module place, the PCB component unique ID will same as Schematic 
component unique ID, then after Import Changes, the component's location will be keep. 
and you can update the track's net follow the schematic netlabel too.

That implement the multipe chanel placing.

Notice:

Module composes by tracks and components, it doesn't same as symbol binding footprint, 
the schematic module can not binding PCB module, after placing, the module will be 
separated by many objects, only the symbol and footprint can be corresponding via 
component ID, that is why you need to make the identication letter unique for placing each 
time to make sure schematic module corresponding with PCB module.

 

Generate Fabrication File Gerber  

When you finish your PCB, you can output the Fabrication Files(gerber file) via: File > Generate 
PCB Fabrication File(Gerber) , or Fabrication > PCB Fabrication File(Gerber).

After clicking, will open the Gerber generate dialog:

   #  Generate Fabrication File(Gerber)1
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You can calculate the price for the PCB order, click SAVE to CART will go to JLCPCB and add your 
PCB in the cart.

Gerber file name  

The generated Gerber file is a compressed zip file. After decompression, you can see the 
following files:

Gerber_BoardOutline.GKO:PCB Border file. The PCB board factory cuts the shape of the 
board according to this document. The groove drawn by the EasyEDA, the solid region(Type: 
NPTH) is reflected in the border file after the Gerber is generated. 
Gerber_TopLayer.GTL:Top side copper layer.
Gerber_BottomLayer.GBL:Bottom side copper layer.
Gerber_Inner1.G1，Gerber_Inner2.G1... :Inner copper layer.
Gerber_TopSilkLayer.GTO:Top silkscreen.
Gerber_BottomSilkLayer.GBO:Bottom silkscreen.
Gerber_TopSolderMaskLayer.GTS:Top solder mask. The default board is covered with 
green oil, and the elements drawn on this layer correspond to the top layer's area will not 
be covered with oil.
Gerber_BottomSolderMaskLayer.GBS:Bottom solder mask. The default board is covered 
with green oil, and the elements drawn on this layer correspond to the bottom layer's area 
will not be covered with oil.
Gerber_Drill_PTH.DRL:Plated drill through hole layer. This document shows the location of 
the hole where the inner wall needs to be metallized.
Gerber_Drill_NPTH.DRL:Non-Plated drill through hole layer. This document shows the 
location of the hole where the inner wall don't need to be metallized. 
Gerber_TopPasteMaskLayer.GTP:Top Paste Mask, for the stencil.
Gerber_BottomPasteMaskLayer.GBP:Bottom Paste Mask, for the stencil.
ReadOnly.TopAssembly:Top Assembly, read only, doesn't affect the PCB manufacture.
ReadOnly.BottomAssembly:Bottom Assembly, read only, doesn't affect the PCB 
manufacture.
ReadOnly.Mechanical:Record the information on the mechanical layer in the PCB design, 
and only use it for information recording. By default, the shape of the layer is not 
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manufactured at the time of production. Some board manufacturers use the mechanical 
layer to make the frame when using Altium file to production. When using Gerber file, it is 
only used for text identification in JLCPCB. For example: process parameters; V cut path etc. 
In EasyEDA, this layer does not affect the shape of the border of the board.

Notice:

Before ordering the PCB, please check the gerber at the Gerber view as below.
The Gerber files are generated by browser, please use the browser inner downloader to 
download!

Gerber View  

Before sending Gerber to the factory, please use gerber viewer to check the Gerber carefully.

local gerber viewer you can use such as: Gerbv, FlatCAM, CAM350, ViewMate, GerberLogix etc.

Gerber viewer recommend Gerbv: 

Project page:http://gerbv.geda-project.org/   
Download: https://sourceforge.net/projects/gerbv/files/

How to use Gerbv:

1.Download Gerber zip file, and download Gerbv, unzip Gerber file and run the Gerbv;

2.Click the +  button at the Gerbv dialog bottom-left corner, open the gerber folder, select all the 
gerber files, and open.

3.And then zoom, measure, check every layer, check drill holes and location. etc.

FlatCAM is a nice tool too: http://flatcam.org/

FlatCAM lets you take your designs to a CNC router. You can open Gerber, Excellon or G-code, 
edit it or create from scatch, and output G-Code. Isolation routing is one of many tasks that 
FlatCAM is perfect for. It's is open source, written in Python and runs smoothly on most 
platforms. 

Free Online Gerber Viewer:
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Recommend：
jlcpcb.com
tracespace.io/view
gerber.ucamco.com    

 

 

Export BOM  
 

You can export the Bill of Materials (BOM) for the schematic (Document) and PCB, via: "Top Menu 
- File - Export BOM", or "Top Menu - Fabriaction - BOM".

  

After clicking the BOM export option, the dialog below will open.

In this dialog，you can click the buttom to assign LCSC part's order code for your components.

After clicking on the assign icon，the components and footprints search dialog will pop up, and 
you can choose which component you want to assign.

https://jlcpcb.com/quote
https://tracespace.io/view/
https://gerber.ucamco.com/
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When you click the "Order Parts/Check Stock" button, we will help you to list all the components 
of your BOM at LCSC.com(If you haven't login LCSC, you have to login first). If you want to buy the 
components form LCSC, and you just need to put them to the cart and check out.

You can open the BOM in any text editor or spreadsheet.

Notice:

If your project has schematic and PCB, the BOM data will come from schematic; if the 
project only has PCB, the BOM data will come from PCB.
In order to support multiple languages, BOM and coordinate files (CSV file) are UNICODE 
encoded and tab-based. If the CSV file cannot be read by your components vendor or PCB 
manufacturer, please convert the encoding and change the delimiter.
Recommended solution: Save as a new CSV file in Excel or WPS. For example, open a CSV file 
in Excel, click or select: Save As - Other Formats - CSV (Comma Separated) (*. csv).



You can also open the CSV file with any text editor (such as Windows Notepad) and save as 
ANSI or UTF-8 encoding. If necessary, replace all tabs with commas.

 

Export Pick and Place File  
 

In PCB editor, if you want to generate Pick And Place as a CSV file, you can via:   

File > Export Pick and Place File  or Top Menu - Fabrication - Pick and Place File.

You can set the options:

  

If your PCB has been panelize by the editor, you can enable the "Include panelized components 
coordinate".

When you open the exported CSV file, you can see:

This file support two units "mm" and "mil", it is following the PCB unit setting.
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There is an option "Mirror the coordinates of the components on the bottom side(Some SMT 
manufacturer may need it, while JLCPCB does not)", you can check with your SMT manufacturer, 
the mostly SMT manufacturer doesn't need it.

Notice：

In order to support multiple languages, BOM and Pick and Place files (CSV file) are UNICODE 
encoded and tab-based. If the CSV file cannot be read by your components vendor or PCB 
manufacturer, please convert the encoding and change the delimiter.
Recommended solution: Save as a new CSV file in Excel or WPS. For example, open a CSV file 
in Excel, click or select: Save As - Other Formats - CSV (Comma Separated) (*. csv).
You can also open the CSV file with any text editor (such as Windows Notepad) and save as 
ANSI or UTF-8 encoding. If necessary, replace all tabs with commas.

 

 

How to Order PCB  

Order Parts  

1. Finish the schematic and PCB design at EasyEDA.
2. Open schematic, click " - Export BOM" button, the BOM dialog will open, click "Order 

Parts/Check Stock" button, will open LCSC.com order page. Check Export BOM
3. Add the parts to the cart, and then submit the payment.

Order PCB  

1. Open PCB, click " - Generate Fabriaction File(Gerber)". Check Generate Fabrication 
File(Gerber) 

2. Before ordering, check the Gerber first:  Gerber Viewer

3. Visit at JLPCB https://jlcpcb.com/quote ,login with EasyEDA accout.

4. Order PCB from EasyEDA editor directly(at Generate) or you can add the Gerber 
file(compressed file, ZIP) on the page and type the order options.

5. If you want to assembly parts, before enable the SMT option, you need to check all your 
parts are using "LCSC Assembled" class libs, and then upload the BOM file and Pick and 
Place file.  

LCSC Assembled Libraries
Export BOM
Generate Fabrication File(Gerber) 

6. Save to the Cart, and then submit the payment.

Doesn't support to combine the components order with the PCB order.

More information please refer at: 

How to place an order

How to order a SMT order

How to order a stencil
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Create The Footprint  

Create The Footprint  

There will be times when you will need a PCB footprint that is not already in the EasyEDA 
libraries.  

Footprint Tool  

The process of creating your own Footprints is very similar to how you make symbols for your 
own Schematic Libs.

Footprint Tools almost are the same as PCB tools, just lacking some of the functions.

  

Create Footprint  

Start a new Footprint as shown below or by doing:

File > New > Footprint

  

This opens the New Footprint editor.

Drawing Steps  

1.Downlod the datasheet which you need to draw the Footprint, such as SOIC-8.Such as PDF：
UC2844BD1R2G
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2.Read the datasheet, notice the 0 degree of the Footprint (The 0 degree is the Footprint's 
direction when you placed it on the PCB without rotation), the right 0 degree will helpful for PCB 
SMT.

3.Check the footprint size, pad/pin direction and polarity, and then place the Pads on the canvas. 
You can adjust the pad size base on your real usage situation.  

Component's pin direction, page 1. 

   

footprint polarity, page 1 and 18.  

  

Depends on page 18, placing one pad on the canvas on the top layer, and then change the 
pad number, size, shape type etc. And then set the coordinate for it, and place the less pads, 
you can use the "Top Menu - Align" tools to align the pads to fit the location. If you want to 
move the pad by mouse or direction key by small steps, you can set a new snap size at the 
right-hand panel.  



4.Drawing the Footprint silk screen. And sometimes you can add some marking and text on the 
mechanical or document layer.

Swicthing layer to TopSlikLayer
Using the Track and Arc to draw the silk screen. The editor doesn't support draw the 
retangle silk screen at present.   

5.Filling the footprint title and prefix at the right-hand "Custom Attributes", and then Save. When 
you save it , please fill the tags, description, the description suggesting add the footprint 
datasheet link and footprint size, that can help you or other people to recognize this Footprint 
whether if it can be used for the design. 

6.Use the dimension tool to check the Footprint size, via: Top Menu - Tools - Check Dimension.

7.Set the origin. You can via: "Top Menu - Place - Set Canvas Origin - By Center of Pads" to set the 
origin.

8.Save.

Then the PCB footprint creating finish .

Notice：

The Origin Point. To simplify rotating your symbols when they are placed into the canvas, 
make sure all of your symbols are created as near as possible centered around that point. 



Suggesting the footprint center to be the origin point. That will helpful to rotation when you 
placing it on the canvas, and help to do the SMT more quickly. 
The pad center suggesting one and more on the grid , avoid when place it on the PCB 
causing the track hard to connect issue.
The pad number can be set as number and alphabet, they must match with the 
SchematicLib's pin number, otherwise the component which was assigned this Footprint will 
alert the error at the footprint manager, and can' not convert the schematic to PCB.
The pad number will increase by placing with mouse, if you copy and paste it, the number 
will not increase.

Others 

It is important to set the right Snap and Grid sizes to ensure that the pads on the finished 
footprint snap exactly to the grid and so connect the nets. For example, if you are creating a 
DIP footprint, set the Grid size to 100mil.

Keep all other shapes such as component outlines and any associated pin identification 
marks or text on the TopSilkLayer. EasyEDA will automatically take care of the actual 
layer assignment when you place the footprint on the PCB.

CTRL+S  to save your footprint designs and you will find them saved into the Libraries > 
Classes: Footprint > Personal > Created section of the left Navigation panel. 

Annular ring of the pad/via is too small, keep the annular ring >= 4mil. In this case, you can 
add a Hole

 

Pad attributes  

You can add pads using the Pads button from the Footprint Tools palette or using the P  hotkey.
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After selecting one of the pads, you can view and adjust its attributes in the right hand 
Properties panel.

  

Number: Remembering the pin numbers you set in the schematic symbol in your Schematic 
symbol: to connect those schematic symbol pins to the pads in your PCB footprint, the 
pad numbers you set here in the Footprint footprint must be the same.

Shape: Round , Rectangular ,  Oval and Polygon.

EasyEDA supports four shapes: Round  ,  Rectangular  , OVAL  and POLYGON .  

OVAL  PAD will give your more space.   
POLYGON  PAD will let you to create some strange pad.  

Like in the image below, you can edit the PADs points when you select a POLYGON  PAD

Layer: If the pads are part of a SMD footprint, you can set it to Top layer or Bottom layer. For 
through hole components you should set it to Multi-Layer.



Net: You don't need to enter anything here because at present this footprint is not connected to 
anything in a circuit.

Width and Height: When the shape is set to Round, Width will equal Height.

Rotation: Here you can set the Pad's rotation as you want.

Hole(D):  This is the drill hole diameter for a through hole pad. For a SMD Pad, set this to zero.

Center-X and Center-Y: using these two attributes, you can set the pad's position with more 
precision, compared to using the mouse.

Plated： Yes or No. when the pad is multi-layer pad, if it set the plated as no, this pad top side 
and bottom side will not be connected together.

 

 

Edit Footprints  

Edit Footprint in Library  

When you found a Footprints(footprint) but it can not be satisfied for your design, you can edit it 
to be your personal PCB footprint.

Via Library > Footprint > Search Component/Personal/LCSC/System > Select footprint > Edit

You can edit the pad size, shape outlines, etc. when you finish and save, it will be saved to your 
personal libraries "Created" and become your personal libraries.

And you can add a tag for your Footprint when you save it:
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Modify the saved Footprint tag at "Library" part list.

 

Edit Footprint in PCB  

If you want to edit a package(footprint) in the PCB, you can use the Ungroup/Group function 
same as the schematic.

On the PCB Tools palette there is the Group/Ungroup Symbol… button.

This tool is for you to quickly create or edit library symbols.

1. Select a footprint
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2. Click the Group/Ungroup Symbol… button
Up to this point you have a collection of separate pads, a drawn silk layer tracks and some 
text that are all separate items with no particular association with each other.

3. Edit the shape or pad what you want to change
4. Select all of the items and click the Group/Ungroup Symbol… button. 

A dialog will be opened:  

After you click OK, all those separate elements will be grouped together to form your new symbol 
directly in the PCB.

Using the group function, you can create/edit any symbol in the Schematic/PCB, easily and 
quickly.

Notice:

Before ungroup the footprint, please change it's layer to top layer first, because of the 
footprint after grouping will at top layer.

 

 

Import PCB 3DLib  

Import 3D File  

EasyEDA supports for importing 3D models, PCB can view cool 3D models when doing 3D 
preview. Exporting PCB 3D model files is not supported yet.

1. Draw or download 3D model  
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Note: currently only 3D models in "WRL(VRML)" and "obj" are supported. WRL can be imported 
directly without the need for compression; Obj must be compressed into a zip file with the MLT 
file and then imported, and the MLT file is usually taken with you when you download the obj file. 
Other formats of 3D files wii be supported in the future.

Note that file suffixes cannot be capitalized.

Download address:

https://library.io/explore/3dmodels    (MLT files are automatically downloaded when obj files are 
downloaded.)

https://github.com/KiCad/kicad-packages3D  

https://www.traceparts.com/zh

https://www.3dcontentcentral.com/

https://grabcad.com/

2. Create a new 3D library  

in "Top Meun - New - PCB 3D Lib".

If you have many 3D libraries, you can zip them to a zip file to import, no more than 10 WRL files 
for one zip file, otherwise it will fail to import.

OBJ format contains many 3D models in one file, you don't need to zip them.

3. Import 3D model.  

You can check which 3D model you want to import.

https://library.io/explore/3dmodels
https://github.com/KiCad/kicad-packages3D
https://www.traceparts.com/zh
https://www.3dcontentcentral.com/
https://grabcad.com/
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4. Specify the 3D model  

Open the PCB or Footprint, and find " - Tools - 3D Model Manager"

 

Specify the imported 3D model for the corresponding footprint, which is basically consistent 
with the footprint manager operation. For the specific use of the tutorial, please see: PCB - 
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3D Model Manager

Adjust the position and parameter relationship between the 3D model and PCB packaging, 
and click update
After completing all the specified 3D models, you can start the 3D preview of the whole PCB.

Edit 3D Lib  

1. The SHIFT+F shortcut opens the component library dialog box
2. Switch to "PCB 3D library" and "WorkSpace"
3. Right click can edit and delete 3D library

FAQ：

Q：Can the official footprint library specify the 3D model first?
A：Yes, later official libraries will specify 3D models. At present, you need to specify to PCB or 
PCB footprint.

Q：Can EasyEDA export the whole PCB 3D format for structural design? Step, etc.
A：It will be supported in the future, step by step, and will directly support importing the step 
format in the future. This format is more complicated and needs time to study.

https://docs.easyeda.com/en/PCB/3D-Model-Manager/index.html
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Q：Will EasyEDA support to draw 3D models in the future?
A：Don't. At present, many 3D rendering tools are very mature (Auto CAD, CAXA, SolidWorks, 
etc.) or open source free (FreeCAD, LibreCAD). Online 3D design tools (onshape) are also 
available.

 

Footprint Naming Rule  

EasyEDA Footprint Naming Rule  

EasyEDA Footprint Naming Rule Reference

Introduction: 

Believe that the vast number of electronic engineers will encounter the problem of footprint 
name naming, and now EasyEDA to provide everyone with a reference scheme - "EasyEDA 
Footprint Naming Rule Reference".

Each company should have its own footprint naming specification,EasyEDA is no exception, 
EasyEDA has more than 180,000 of official library (LCSC library), multiple engineers in the 
construction of footprint, more need unified library rules and footprint naming rules to ensure 
library consistency and footprint reuse.

Written by LCSC engineering department and EasyEDA team, after close one year of running in, 
now we are very happy to release the "EasyEDA Footprint Naming Rule Reference".

EasyEDA has been established according to the new footprint naming specification Footprints for 
more than half a year, and EasyEDA will continue to draw new library according to this rule.

af://n3849
af://n3851


The majority of EasyEDA users can also according to this rule:

1. Find the components of the specified package type;
2. Create your own or team's or company's footprint according to this rule;
3. Quickly reuse the official footprint.

Characteristics:

1. The rules of "package type _ feet number - body width - foot distance - body length - foot 
azimuth - polarity direction _ series name" are adopted in naming, so that users can quickly 
and clearly footprint most of the information

2. It covers most common component classification and encapsulation types and can quickly 
locate and query

3. Continuously expand new naming rules according to new components or packaging types, 
and continuously update and maintain

4. Public distribution, free of charge for both individuals and enterprises

Disadvantages:

Titles of some footprint types are too long

Update record:

2019.12.27 First release

Download:

Download: EasyEDA Footprint Naming Rule Reference.pdf

 

 

Import Image  

Import Image to Schematic  

When you select Image from the Drawing Tools palette, an image place holder will be inserted 
into the canvas:

Select the place holder, so you can see the image's attributes in the right hand Properties panel:

https://easyeda.com/forum/topic/EasyEDA-Footprint-Naming-Rule-Reference-9b470b52aeca46228b446f1fc0e323f0
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Set the URL of your image. For example, setting the URL to:

http://upload.wikimedia.org/wikipedia/commons/thumb/c/c7/555_Pinout.svg/220px-
555_Pinout.svg.png

will make your image look like this:

Please note: at present, EasyEDA cannot host images, so you need to upload your images to an 
image sharing site such as http://www.imgur.com.

 

Import Image to PCB  

On PCB and Footprint editor, there is a nice feature on the PCB Tools bar.

http://upload.wikimedia.org/wikipedia/commons/thumb/c/c7/555_Pinout.svg/220px-555_Pinout.svg.png
http://www.imgur.com/
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After clicking on the image icon, you will see the Insert Image window as below.

In this dialog, you can choose your favorite image, EasyEDA support JPG , BMP , PNG , GIF , and 
SVG . Unlike some other EDA tools which only support a Monochrome Bitmap image, EasyEDA 
supports full color, but Monochrome Bitmap is welcome.

You can adjust the color tolerance, simplify level and reset the image size there.

And you can select shape invert. 

The image will be inserted to the active layer, if it is not right, you can change the attribute. Such 
as TopSilkLayer.  
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Import DXF File  
 

How to create irregular board outlines or complex board outline in EasyEDA? 
This is sometimes needed when you are designing a PCB for an enclosure that may have a 
curved profile, or other unavoidable mechanical features for which one must design.  

EasyEDA supports that import DXF into PCB.

Find the import DXF menu under the file menu. Via: File - Import - DXF  

  

After selecting the *.DXF file, you will find a dialog like in the image below
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EasyEDA provides some options, unit(mm, cm, mil, inch), and select the layer to which the shapes 
will be applied.

If you import DXF into schematic or symbol, its unit is pixel.

After clicking the import button, you will find them on your PCB canvas.



You can try this to import this example by yourself. DXF example  

Please note:  

1. The file must have a *.dxf filename extension.
2. The circles will be converted to holes if you choose the layer as board outline.  
3. There are some items which are not supported. Such as Mirror, spiral line etc. 
4. If the DXF objects were grouped, please ungroud them before importing.
5. Do not import the big DXF to copper layer directly, it will make the editor stuck a period of 

time.

 

Import Altium Designer  
The import function is beta now, please check carefully after imported.

Some design rules EasyEDA doesn't support yet.

Import Schematic and PCB  

1. You can import Altium Designer's Schematic and PCB files into EasyEDA but only 
from ASCII files, so you need to save the designs as Ascii files like this.

https://image.easyeda.com/files/test.dxf
af://n3935
af://n3938


Then import it via: File - Open - Altium...

  

 

EasyEDA offers an excellent experience in importing Alitum Designer's Schematic and PCB as you 
can see from the image below of a schematic imported from Altium Designer:



If your schematic and PCB are Protel 99se format files, please open at Altium Designer and save 
as ASCII format, and then import them. EasyEDA don't support Protel 99se file format directly.

2. If you import Altium schematic found some text became unreachable code, please encode 
your ASCII file with UTF-8. 

Notice:

EasyEDA doesn't sopport to import the Alitum PCB rules now.
EasyEDA doesn't sopport to import the Alitum PCB inner plane layer, please modify 
manually after imported.
EasyEDA doesn't sopport to import the Alitum IEEE symbol of the schematic now.

Please do not export your design to Alitum and import it again and again, that will cause 
some detail missing!!!
If the Alitum file very large that will using a long time to import, suggested remove the 
copper first before importing.

Import Altium libraries  

af://n3964


Altium Designer's Schematic and Footprintraries are not available as ASCII files, EasyEDA can't 
import them directly, so how can you import them?

In the Import file from your computer dialog to the right of File Operation; tick the Extract 
Libs  option and EasyEDA will extract all of the libs from the Schematic files or PCB Files. 

So, if you want to import Altium Designer's Libs, you can add them to your Altium Designer 
Schematic or PCB and then extract them again into your EasyEDA library.

  

Import Eagle  

Please refer next section

Import KiCAD  

Please refer next section

 

Import Eagle  
Eagle Schematic/PCB/libs can be imported, but EasyEDA can only support version 6 and later (6+) 
because that was when Version 6 Eagle adopted an ASCII XML data structure as their native file 
format.

af://n3970
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If your Eagle file can be open in Eagle, but can't be imported in EasyEDA, you can save as a copy 
with the latest Eagle, and then import it.

If you make sure you have been saved as a copy from v6.0 and greater, but importing still fail, 
then please edit the Eagle file at Text Editor, find out the Garbled characters, and remove it, and 
then try again.

If your schematic needs to update the PCB, please use "Import File and Extract Libs" option, 
make sure all libraries are imported first.

Some rule or primitive doesn't support, please check carefully after importing.

 

 

Import KiCAD  
EasyEDA support import KiCAD v4.06 and greater version KiCAD files, if the KiCAD files version 
less then v4.06, please open them at the latest KiCAD and save as a new one, and then import 
them.
The KiCAD project files need to be compressed as zip file before importing.

af://n3985


If you only want to import the PCB, you just need to ZIP the PCB file and then import it.
If you want to import the schematic, you must ZIP the schematic and symbols together, 
suggested using KiCAD archive tool when open the project in KiCAD, it will including the 
symbols in the ZIP file automatically.

  

Notice

For the KiCAD special symbols such as Power symbol (Power Flag(PWR_FLAG)), EasyEDA will 
convert them as the symbol not Netflag, you can delete them if you don't need them.
The PCB design rule doesn't support yet.
KiCAD has been update document format since KiCad v5.1.3, if you importing fail, please try 
the lower version. It is waiting for fixed.

 

 

Export BOM  
 

You can export the Bill of Materials (BOM) for the schematic (Document) and PCB, via: "Top Menu 
- File - Export BOM", or "Top Menu - Fabriaction - BOM".

af://n4005


  

After clicking the BOM export option, the dialog below will open.

In this dialog，you can click the buttom to assign LCSC part's order code for your components.

After clicking on the assign icon，the components and footprints search dialog will pop up, and 
you can choose which component you want to assign.



When you click the "Order Parts/Check Stock" button, we will help you to list all the components 
of your BOM at LCSC.com(If you haven't login LCSC, you have to login first). If you want to buy the 
components form LCSC, and you just need to put them to the cart and check out.

You can open the BOM in any text editor or spreadsheet.

Notice:

If your project has schematic and PCB, the BOM data will come from schematic; if the 
project only has PCB, the BOM data will come from PCB.
In order to support multiple languages, BOM and coordinate files (CSV file) are UNICODE 
encoded and tab-based. If the CSV file cannot be read by your components vendor or PCB 
manufacturer, please convert the encoding and change the delimiter.
Recommended solution: Save as a new CSV file in Excel or WPS. For example, open a CSV file 
in Excel, click or select: Save As - Other Formats - CSV (Comma Separated) (*. csv).
You can also open the CSV file with any text editor (such as Windows Notepad) and save as 
ANSI or UTF-8 encoding. If necessary, replace all tabs with commas.

 

 

Export NetList  
EasyEDA can export the netlist for the whole active project:

File > Export NetList > Spice...

af://n4028


  

EasyEDA can export a netlist in a variety of formats: 

LTSpice for this Sheet: this is a Spice compatible netlist generated by the simulation engine 
of EasyEDA, It is not normally used as the basis for as a PCB layout.
Protel/Altium for PCB: a PCB netlist in a format that can be imported straight into Altium 
Designer and it's predecessor, Protel. 
PADS for PCB: a PCB netlist in a format that can be imported straight into Pads PCB layout 
tools.
FreePCB for PCB: a PCB netlist in a format that can be imported straight into FreePCB, a 
 free, open source PCB editor for Windows.

 

 

Export PCB  
 

Export PCB in PDF/PNG/SVG  

Exporting a PCB design or footprints from EasyEDA is very similar to exporting a Schematic or a 
Symbol.

Via: File > Export > PDF/PNG/SVG…

af://n4045
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You will open this dialog:



You can select to export in PDF, PNG or SVG format.

Note: *The PDF size is zoom as 1:1 with PCB. *

Export to: Support export to PDF, PNG, SVG. If you want to print the PCB 1:1, please choose 
PDF.

Engine:

Local: PDF generated by Editor
Cloud: PDF generated by Cloud Server, in the future, EasyEDA will remove this option.

Graphics:

Full Graphics: All graphics, objects will be exported. 

Assembley Drawings: Only exporting components's prefix and location, hole etc. This 
is for part assembly. 



Object Outline: Only exporting objects' outline, such as Pad and silkscreen outline.

Type:

Merged layer: All selected layers you want to export will be merged in one page.
Paged layer: All selected layers you want to export will be paged in one file.
Separated layer: All selected layers you want to export will be separated in multiple 
files. Export as a ZIP file.

Color: You can choose "Black on White", "White on Black", "Full Color".

Layer: You can select to print individual layers or selected layers merged into a single file.

Mirror: It is also possible to mirror selected layers for example to show bottom layers in 
easily readable orientation. Recommend when all your selected layers are bottom type you 
can enable this option.

If EasyEDA PDF can not satisfy your requirement, please let us know.

  

And if you generated the Gerber file, you can use the Gerbv to export the PDF, it is very easy.

Via Gerbv

 

Export PCB in Altium Designer Format  

The more information please refer at Export Altium

Download PCB  

Please refer at Export EasyEDA Source

Print PCB and Etching  

EasyEDA doesn't support to print PCB directly, please export PDF and print.

If you don't want to order your PCBs from EasyEDA then maybe - for single and double sided PCB 
designs -  you might like to try like using some home made PCB tech:

https://docs.easyeda.com/en/Export/Export-Gerber-Files/index.html#Gerber-View
af://n4093
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http://hackaday.com/2012/12/10/10-ways-to-etch-pcbs-at-home/

So here's how you can print your PCB layer by layer and then etch it onto a PCB.

Step 1) Export it to PDF, Using: File > Export > PDF…

Note: Make sure the Colour is Black on White Background.

Generally choose the bottom layer. Select if you want to mirror the export as needed.

If you have routed PCB tracks on the top layer, then you need to choose the top layer. Etch PCB 
by themselves generally need to mirror export printing.

Step 2) Open the pdf file in a viewer

http://hackaday.com/2012/12/10/10-ways-to-etch-pcbs-at-home/


Step 3) Print it to paper

Step 4) Copy it to the copper

Step 5) Etch it

Step 6) Drill it



Step 7) Get your soldering iron out!

 

 

 

Generate Fabrication File(Gerber)  

Generate Fabrication File Gerber  

When you finish your PCB, you can output the Fabrication Files(gerber file) via: File > Generate 
PCB Fabrication File(Gerber) , or Fabrication > PCB Fabrication File(Gerber).

af://n4123
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After clicking, will open the Gerber generate dialog:

You can calculate the price for the PCB order, click SAVE to CART will go to JLCPCB and add your 
PCB in the cart.

Gerber file name  

The generated Gerber file is a compressed zip file. After decompression, you can see the 
following files:

Gerber_BoardOutline.GKO:PCB Border file. The PCB board factory cuts the shape of the 
board according to this document. The groove drawn by the EasyEDA, the solid region(Type: 
NPTH) is reflected in the border file after the Gerber is generated. 
Gerber_TopLayer.GTL:Top side copper layer.
Gerber_BottomLayer.GBL:Bottom side copper layer.
Gerber_Inner1.G1，Gerber_Inner2.G1... :Inner copper layer.
Gerber_TopSilkLayer.GTO:Top silkscreen.
Gerber_BottomSilkLayer.GBO:Bottom silkscreen.
Gerber_TopSolderMaskLayer.GTS:Top solder mask. The default board is covered with 
green oil, and the elements drawn on this layer correspond to the top layer's area will not 
be covered with oil.
Gerber_BottomSolderMaskLayer.GBS:Bottom solder mask. The default board is covered 
with green oil, and the elements drawn on this layer correspond to the bottom layer's area 
will not be covered with oil.
Gerber_Drill_PTH.DRL:Plated drill through hole layer. This document shows the location of 
the hole where the inner wall needs to be metallized.
Gerber_Drill_NPTH.DRL:Non-Plated drill through hole layer. This document shows the 
location of the hole where the inner wall don't need to be metallized. 
Gerber_TopPasteMaskLayer.GTP:Top Paste Mask, for the stencil.
Gerber_BottomPasteMaskLayer.GBP:Bottom Paste Mask, for the stencil.
ReadOnly.TopAssembly:Top Assembly, read only, doesn't affect the PCB manufacture.
ReadOnly.BottomAssembly:Bottom Assembly, read only, doesn't affect the PCB 
manufacture.

af://n4131


ReadOnly.Mechanical:Record the information on the mechanical layer in the PCB design, 
and only use it for information recording. By default, the shape of the layer is not 
manufactured at the time of production. Some board manufacturers use the mechanical 
layer to make the frame when using Altium file to production. When using Gerber file, it is 
only used for text identification in JLCPCB. For example: process parameters; V cut path etc. 
In EasyEDA, this layer does not affect the shape of the border of the board.

Notice:

Before ordering the PCB, please check the gerber at the Gerber view as below.
The Gerber files are generated by browser, please use the browser inner downloader to 
download!

Gerber View  

Before sending Gerber to the factory, please use gerber viewer to check the Gerber carefully.

local gerber viewer you can use such as: Gerbv, FlatCAM, CAM350, ViewMate, GerberLogix etc.

Gerber viewer recommend Gerbv: 

Project page:http://gerbv.geda-project.org/   
Download: https://sourceforge.net/projects/gerbv/files/

How to use Gerbv:

1.Download Gerber zip file, and download Gerbv, unzip Gerber file and run the Gerbv;

2.Click the +  button at the Gerbv dialog bottom-left corner, open the gerber folder, select all the 
gerber files, and open.

3.And then zoom, measure, check every layer, check drill holes and location. etc.

FlatCAM is a nice tool too: http://flatcam.org/

FlatCAM lets you take your designs to a CNC router. You can open Gerber, Excellon or G-code, 
edit it or create from scatch, and output G-Code. Isolation routing is one of many tasks that 
FlatCAM is perfect for. It's is open source, written in Python and runs smoothly on most 
platforms. 

Free Online Gerber Viewer:

af://n4171
http://gerbv.geda-project.org/
https://sourceforge.net/projects/gerbv/files/latest/download?source=files
http://flatcam.org/download


Recommend：
jlcpcb.com
tracespace.io/view
gerber.ucamco.com    

 

 

Export Pick and Place File  
 

In PCB editor, if you want to generate Pick And Place as a CSV file, you can via:   

File > Export Pick and Place File  or Top Menu - Fabrication - Pick and Place File.

You can set the options:

  

If your PCB has been panelize by the editor, you can enable the "Include panelized components 
coordinate".

https://jlcpcb.com/quote
https://tracespace.io/view/
https://gerber.ucamco.com/
af://n4191


When you open the exported CSV file, you can see:

This file support two units "mm" and "mil", it is following the PCB unit setting.

There is an option "Mirror the coordinates of the components on the bottom side(Some SMT 
manufacturer may need it, while JLCPCB does not)", you can check with your SMT manufacturer, 
the mostly SMT manufacturer doesn't need it.

Notice：

In order to support multiple languages, BOM and Pick and Place files (CSV file) are UNICODE 
encoded and tab-based. If the CSV file cannot be read by your components vendor or PCB 
manufacturer, please convert the encoding and change the delimiter.
Recommended solution: Save as a new CSV file in Excel or WPS. For example, open a CSV file 
in Excel, click or select: Save As - Other Formats - CSV (Comma Separated) (*. csv).
You can also open the CSV file with any text editor (such as Windows Notepad) and save as 
ANSI or UTF-8 encoding. If necessary, replace all tabs with commas.

 

 

Export DXF  
 

EasyEDA support to export PCB to DXF.

At present only support Board Outline, Hole, NPTH, PTH etc.

EasyEDA does't support to export the DXF which is seperated the layers and objects.

af://n4209


Other side, you can export the PDF, and the using the CAD tool convert PDF to DXF.

 

 

Export Altium Designer Format  
EasyEDA support exporting the schematics and PCB in Altium Designer format.

The "export to Altium" function is beta now, Please check carefully after exported the 
design to Altium, EasyEDA cannot guarantee that is no errors!!! EasyEDA does not bear any 
loss due to library errors and format conversion!!! If you do not agree, please do not carry 
out Altium export!!!

If you want to order the PCB please generate the Gerber instead of exporting to Altium!
Please do not export your design to Alitum and import it again and again, that will cause 
some details missing!!!
Doesn't support Alitum 19 yet, please open exported file at Altium 18 and less, recommend 
Altium 17

If you find out some incorrect detail, please contact us to fix, including detail and files.

  

When exporting, you don't need to save document at firstly, but you need to login.

Exporting Schematics In Altium Designer Format  

EasyEDA support exporting the schematics in Altium Designer format.
Via "File >  Export > Altium...", and click the "Download" you will get  a  .schdoc  file.

 

Exporting PCB in Altium Designer Format  

EasyEDA support exporting the PCB in Altium Designer format.
Via "File >  Export > Altium..." you will get  a  .pcbdoc  file.  

af://n4218
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When open the exported PCB file at Altium Designer, there will open a dialog of DXP Import 
Wizard, don't worry, just cancel it to continue.

Known Issue:  

1. No Copper Area fill data.
And then, you will see the PCB file, which is looks like without copper area as below:

af://n4235


You need to repour all polygons at Altium Designer. Via: Tools > Polygon Pours > Repour 
All:

 



And the last, save it. 

2. No Ratlines.

If you export the PCB without ratlines, you need to show all connections first before routing :
Via: Design > Netlist > Clean All Nets (D > N > A),and then (V > C > S)

Or use hotkey: N > H > A and then N > S > A:  

3. Inner layer Plane Zone doesn't export perfectly.

You need to rebuild the plane zone, and re-assgin plane zone's net.

4. Doesn't support DRC rule.

Please check the DRC manually.

5. The text may be changed.



Because of the font family, some text maybe will change the position. And it maybe will display 
incorrect, please modify the text manually.

 

Exporting Footprint and Symbol in Altium Designer
Format

 

EasyEDA don't support to export the Symbol or Footprint as Altium Designer library format, but 
you can place the libraries to the schematic or PCB, and export that in Altium Designer format, 
and then extract the libraries at Altium Designer.

EasyEDA does not bear any loss due to library errors and format conversion!!! If you do not 
agree, please do not carry out Altium export!!!

 

 

 

Export SVG Source  
 

EasyEDA support to export or edit SVG source.

You can create an SVG source file via: 

File > Export > SVG source...

then copy the contents of this box into a text editor and save the file with a .svg extension. You 
can edit it in Inkscape or open it in your browser.

This solution doesn't need an Internet connection you can use it off-line on EasyEDA.

 

 

Export EasyEDA Source  

af://n4257
af://n4264
http://www.inkscape.org/
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EasyEDA support you save your file to local, you can download your design as EasyEDA source 
file.

1. Export EasyEDA document directly

You can create an EasyEDA source file via: 

** > File >  EasyEDA File Source...**

2. Download the project

Via： Project folder > Right Click > Download, you will download a zip file with EasyEDA Source 
files for Schematics and PCBs.

Or you can backup the projects, via: Project folder > Right Click > Backup Project



it will open a dialog, you can select the projects what you want to backup. There is only backup 
projects once per day.

EasyEDA Source File is a JSON file which can be read by many other programs. JSON format 
please see:

http://en.wikipedia.org/wiki/JSON

3. Open EasyEDA File

If you want to open the EasyEDA file you exported, you can try: " - File - Open - EasyEDA...".

  

Then you can edit and save the document.

 �

http://en.wikipedia.org/wiki/JSON
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